summaryrefslogtreecommitdiff
path: root/net-mgmt/mbrowse/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/mbrowse/Makefile')
-rw-r--r--net-mgmt/mbrowse/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-mgmt/mbrowse/Makefile b/net-mgmt/mbrowse/Makefile
new file mode 100644
index 000000000000..c795db7f45ef
--- /dev/null
+++ b/net-mgmt/mbrowse/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mbrowse
+# Date created: Apr 4, 2002
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mbrowse
+PORTVERSION= 0.2.3
+CATEGORIES= net
+MASTER_SITES= http://goldplated.atlcartel.com/
+
+MAINTAINER= markp@FreeBSD.org
+
+LIB_DEPENDS= snmp.4:${PORTSDIR}/net/net-snmp
+
+GNU_CONFIGURE= yes
+USE_GTK= yes
+CONFIGURE_ARGS+= --with-ucdsnmp-prefix=${LOCALBASE}
+
+post-patch:
+ @${PERL} -pi -e 'print "#include <sys/types.h>\n" if !$$a; $$a=1' \
+ ${WRKSRC}/src/callbacks.h
+
+.include <bsd.port.mk>