summaryrefslogtreecommitdiff
path: root/net-mgmt/cacti88-spine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/cacti88-spine/Makefile')
-rw-r--r--net-mgmt/cacti88-spine/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-mgmt/cacti88-spine/Makefile b/net-mgmt/cacti88-spine/Makefile
new file mode 100644
index 000000000000..dae1b054d227
--- /dev/null
+++ b/net-mgmt/cacti88-spine/Makefile
@@ -0,0 +1,40 @@
+# Created by: clement@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= spine
+PORTVERSION= 0.8.8h
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.cacti.net/downloads/${PORTNAME}/
+PKGNAMEPREFIX= cacti88-
+DISTNAME= cacti-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= egypcio@googlemail.com
+COMMENT= Multithreaded poller for Cacti written in C
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= help2man:misc/help2man
+LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp \
+ libpkg.so:ports-mgmt/pkg
+
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} --with-snmp=${LOCALBASE}
+CPPFLAGS+= `net-snmp-config --cflags`
+LDFLAGS+= `net-snmp-config --libs`
+USES= libtool mysql ssl
+
+CONFLICTS_INSTALL= cacti spine
+
+PORTSCOUT= limit:^0.*
+
+post-patch:
+ @${REINPLACE_CMD} 's,#define\ *DEFAULT_CONF_FILE .*,#define DEFAULT_CONF_FILE "${PREFIX}/etc/spine.conf",' ${WRKSRC}/spine.h
+
+do-build:
+ @cd ${WRKSRC}; ${MAKE}
+
+post-install:
+ ${MV} ${STAGEDIR}${PREFIX}/etc/spine.conf.dist ${STAGEDIR}${PREFIX}/etc/spine.conf.sample
+
+.include <bsd.port.mk>