summaryrefslogtreecommitdiff
path: root/net-im/folks/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/folks/Makefile')
-rw-r--r--net-im/folks/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-im/folks/Makefile b/net-im/folks/Makefile
new file mode 100644
index 000000000000..dc4484a65f19
--- /dev/null
+++ b/net-im/folks/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: folks
+# Date created: 23 July 2010
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/net-im/folks/Makefile,v 1.8 2010/10/26 08:47:55 kwm Exp $
+#
+
+PORTNAME= folks
+PORTVERSION= 0.2.1
+CATEGORIES= net-im
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= library to aggregates people from multiple sources
+
+BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen \
+ g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+LIB_DEPENDS= gee.2:${PORTSDIR}/devel/libgee \
+ telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include " \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_SUB= VERSION=16
+
+.include <bsd.port.mk>