summaryrefslogtreecommitdiff
path: root/misc/ossp-uuid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/ossp-uuid/Makefile')
-rw-r--r--misc/ossp-uuid/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index 710bd31b244c..9f4c8327b300 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -6,23 +6,35 @@
#
PORTNAME= uuid
-PORTVERSION= 1.0.1
+PORTVERSION= 1.1.0
CATEGORIES= misc devel
MASTER_SITES= ${MASTER_SITE_OSSP}
MASTER_SITE_SUBDIR= lib/${PORTNAME}
PKGNAMEPREFIX= ossp-
MAINTAINER= ports@FreeBSD.org
-COMMENT= An ISO-C API and CLI for generating Universally Unique Identifiers
+COMMENT= An ISO-C & Perl API and CLI for generating Universally Unique Identifiers (UUID)
CONFLICTS= e2fsprogs-[0-9]*
USE_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS+= --disable-shared --enable-static
MAN1= uuid-config.1 uuid.1
MAN3= uuid.3
+.if !defined(WITHOUT_PERL)
+USE_PERL5= yes
+CONFIGURE_ENV+= PERL=${PERL5}
+CONFIGURE_ARGS+= --with-perl
+PLIST_SUB+= WITH_PERL=''
+MAN3= OSSP::uuid.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+.else
+PLIST_SUB+= WITH_PERL='@comment '
+.endif
+
test:
cd ${WRKSRC}; ${MAKE} check