summaryrefslogtreecommitdiff
path: root/misc/metromap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/metromap/Makefile')
-rw-r--r--misc/metromap/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/misc/metromap/Makefile b/misc/metromap/Makefile
index 85fa8c5bb9be..3e43c27cc70f 100644
--- a/misc/metromap/Makefile
+++ b/misc/metromap/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= metromap
-PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTVERSION= 0.1.2
CATEGORIES= misc
MASTER_SITES= http://metromap.antex.ru/ \
http://www.amdmi3.ru/distfiles/
@@ -18,10 +17,12 @@ COMMENT= A simple application for finding paths in different subways maps
USE_PYTHON= yes
USE_GNOME= pygtk2
USE_BZIP2= yes
-NO_BUILD= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
post-patch:
@${REINPLACE_CMD} -e 's,/usr,${PREFIX},' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's,make,${GMAKE},' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,/usr/bin/python,${SETENV} python,' ${WRKSRC}/metromap.py
.include <bsd.port.mk>