summaryrefslogtreecommitdiff
path: root/mail/thunderbird/files/patch-bug1338655
diff options
context:
space:
mode:
Diffstat (limited to 'mail/thunderbird/files/patch-bug1338655')
-rw-r--r--mail/thunderbird/files/patch-bug133865566
1 files changed, 66 insertions, 0 deletions
diff --git a/mail/thunderbird/files/patch-bug1338655 b/mail/thunderbird/files/patch-bug1338655
new file mode 100644
index 000000000000..2471ca987e12
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1338655
@@ -0,0 +1,66 @@
+commit bbd48a5613c8
+Author: Ralph Giles <giles@mozilla.com>
+Date: Fri Feb 10 12:58:18 2017 -0800
+
+ Bug 1338655 - Don't try to build mp4parse bindings. r=froydnj
+
+ We use the cheddar crate to generate a C header file
+ for our mp4parse_capi wrapper crate. Currently we
+ do this at code check-in time via update-rust.sh.
+
+ Cargo 0.18 and later will try to execute a build.rs
+ file in the crate source tree regardless of whether
+ it's specified in Cargo.toml so patching out that
+ line just results in 'crate cheddar not found'.
+
+ This change restores the old behaviour by substituting
+ a 'build = false' line instead.
+
+ We do have syntex vendored, but we don't currently build
+ it by default, so I prefer this solution to just vendoring
+ cheddar and generating the header at build time. The syntex
+ crate is quite large and adds significantly to our compile
+ time.
+
+ MozReview-Commit-ID: InJRRODWAdP
+
+ --HG--
+ extra : rebase_source : 29378fcbc86015ce6cc22dc66d38a43ddbac204e
+---
+ media/libstagefright/binding/mp4parse-cargo.patch | 5 +++--
+ media/libstagefright/binding/mp4parse_capi/Cargo.toml | 2 ++
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git media/libstagefright/binding/mp4parse-cargo.patch media/libstagefright/binding/mp4parse-cargo.patch
+index 1dd13d20472a..bfa0ab74b424 100644
+--- mozilla/media/libstagefright/binding/mp4parse-cargo.patch
++++ mozilla/media/libstagefright/binding/mp4parse-cargo.patch
+@@ -25,12 +25,13 @@ diff --git a/media/libstagefright/binding/mp4parse_cap
+ index aeeebc65..5c0836a 100644
+ --- a/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+ +++ b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+-@@ -18,17 +18,9 @@ exclude = [
++@@ -18,17 +18,11 @@ exclude = [
+ "*.mp4",
+ ]
+
+ -build = "build.rs"
+--
+++build = false
++
+ [dependencies]
+ "mp4parse" = {version = "0.6.0", path = "../mp4parse"}
+
+diff --git media/libstagefright/binding/mp4parse_capi/Cargo.toml media/libstagefright/binding/mp4parse_capi/Cargo.toml
+index aee7ee947151..d7e3f55119d3 100644
+--- mozilla/media/libstagefright/binding/mp4parse_capi/Cargo.toml
++++ mozilla/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+@@ -18,6 +18,8 @@ exclude = [
+ "*.mp4",
+ ]
+
++build = false
++
+ [dependencies]
+ byteorder = "1.0.0"
+ "mp4parse" = {version = "0.6.0", path = "../mp4parse"}