summaryrefslogtreecommitdiff
path: root/mail/pine4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/pine4/Makefile')
-rw-r--r--mail/pine4/Makefile82
1 files changed, 37 insertions, 45 deletions
diff --git a/mail/pine4/Makefile b/mail/pine4/Makefile
index 146ec958622b..2bc94b31ba4c 100644
--- a/mail/pine4/Makefile
+++ b/mail/pine4/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= pine
-PORTVERSION= 4.51
+PORTVERSION= 4.53
CATEGORIES= mail news
MASTER_SITES= ftp://ftp.cac.washington.edu/pine/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= DougB@FreeBSD.org
-LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
-
# Define "WITH_LDAP" to include ldap support.
# If the ldap port is installed somewhere other than /usr/local, define
# LDAP_PREFIX as well.
@@ -24,36 +22,37 @@ LDAP_PREFIX?= ${LOCALBASE}
BUILD_DEPENDS+= ${LDAP_PREFIX}/lib/libldap.a:${PORTSDIR}/net/openldap
.endif
-.if defined(WITH_SSL)
+.if defined(WITHOUT_SSL)
+MAKE_ARGS+= SSLTYPE=none
+.else
USE_OPENSSL= yes
-EXTRA_OPTS= SSL_LINK="-L${OPENSSLLIB} -lssl -lcrypto"
+EXTRA_OPTS= SSLINCLUDE=${OPENSSLINC} SSLLIB=${OPENSSLLIB}
+.if defined(WITH_SSL_AND_PLAINTEXT)
+EXTRA_OPTS+= SSLTYPE=unix
+.else
+EXTRA_OPTS+= SSLTYPE=unix.nopwd
+.endif
.endif
-MAN1= pine.1 pico.1 pilot.1
+MAN1= pine.1 pico.1 pilot.1 rpdump.1 rpload.1
pre-fetch:
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
${SH} pkg-install
- ${SH} pkg-libwarning
.endif
post-patch:
- @for i in ${WRKSRC}/doc/pine.1 \
- ${WRKSRC}/pine/init.c \
- ${WRKSRC}/pine/pine.hlp \
- ${WRKSRC}/pine/mailcap.c \
- ${WRKSRC}/pine/osdep/os-bsf.h ; do \
- ${MV} $$i $$i.sed ; \
- ${SED} -e "s:@@PREFIX@@:${PREFIX}:g" \
- $$i.sed >$$i ; \
- ${RM} $$i.sed ; \
- done
+.for file in doc/pine.1 pine/init.c pine/pine.hlp pine/mailcap.c \
+ pine/osdep/os-bsf.h
+ @${CP} ${WRKSRC}/${file} ${WRKSRC}/${file}.presed
+ @${SED} -e "s:@@PREFIX@@:${PREFIX}:g" ${WRKSRC}/${file}.presed > \
+ ${WRKSRC}/${file}
+.endfor
@for i in ${WRKSRC}/doc/tech-notes.txt \
${WRKSRC}/doc/tech-notes/*.html ; do \
- ${MV} $$i $$i.sed ; \
+ ${CP} $$i $$i.presed ; \
${SED} -e "s:/usr/local/lib/:${PREFIX}/etc/:g" \
- $$i.sed >$$i ; \
- ${RM} $$i.sed ; \
+ $$i.presed > $$i ; \
done
.if defined(WITH_LDAP)
${MKDIR} ${WRKSRC}/ldap
@@ -65,34 +64,27 @@ do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ./build bsf ${EXTRA_OPTS})
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/pico ${PREFIX}/bin/pico
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/pilot ${PREFIX}/bin/pilot
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/pine ${PREFIX}/bin/pine
- ${SED} -e 's,@@PREFIX@@,${PREFIX},g' \
- < ${FILESDIR}/pgpdecode > ${WRKSRC}/bin/pgpdecode
- ${SED} -e 's,@@PREFIX@@,${PREFIX},g' \
- < ${FILESDIR}/pgpencrypt > ${WRKSRC}/bin/pgpencrypt
- ${SED} -e 's,@@PREFIX@@,${PREFIX},g' \
- < ${FILESDIR}/pgpsign > ${WRKSRC}/bin/pgpsign
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/pgpencrypt ${PREFIX}/bin/pgpencrypt
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/pgpdecode ${PREFIX}/bin/pgpdecode
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/pgpsign ${PREFIX}/bin/pgpsign
- ${SED} -e 's,@@PREFIX@@,${PREFIX},g' \
- < ${FILESDIR}/dot.pinerc.pgp.sample \
+.for program in ${MAN1}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${program:R} ${PREFIX}/bin
+.endfor
+.for script in pgpdecode pgpencrypt pgpsign
+ ${SED} -e 's,@@PREFIX@@,${PREFIX},g' ${FILESDIR}/${script} > \
+ ${WRKSRC}/bin/${script}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${script} ${PREFIX}/bin
+.endfor
+ ${SED} -e 's,@@PREFIX@@,${PREFIX},g' ${FILESDIR}/dot.pinerc.pgp.sample \
> ${WRKSRC}/dot.pinerc.pgp.sample
${INSTALL_DATA} ${WRKSRC}/dot.pinerc.pgp.sample \
- ${PREFIX}/etc/dot.pinerc.pgp.sample
- ${INSTALL_MAN} ${WRKSRC}/doc/pico.1 ${PREFIX}/man/man1/pico.1
- ${INSTALL_MAN} ${WRKSRC}/doc/pilot.1 ${PREFIX}/man/man1/pilot.1
- ${INSTALL_MAN} ${WRKSRC}/doc/pine.1 ${PREFIX}/man/man1/pine.1
+ ${PREFIX}/etc/dot.pinerc.pgp.sample
+.for manpage in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${manpage} ${PREFIX}/man/man1
+.endfor
.if !defined(NOPORTDOCS)
- ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} \
- ${PREFIX}/share/doc/pine \
- ${PREFIX}/share/doc/pine/tech-notes
- ${INSTALL_DATA} ${WRKSRC}/doc/brochure.txt ${PREFIX}/share/doc/pine
- ${INSTALL_DATA} ${WRKSRC}/doc/tech-notes.txt ${PREFIX}/share/doc/pine
- ${INSTALL_DATA} ${WRKSRC}/doc/tech-notes/*.html \
- ${PREFIX}/share/doc/pine/tech-notes/
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} ${DOCSDIR} \
+ ${DOCSDIR}/tech-notes
+ ${INSTALL_DATA} ${WRKSRC}/doc/brochure.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/tech-notes.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/tech-notes/*.html ${DOCSDIR}/tech-notes
.endif
post-install: