summaryrefslogtreecommitdiff
path: root/lang/itcl/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/itcl/files')
-rw-r--r--lang/itcl/files/Makefile.lib4
-rw-r--r--lang/itcl/files/patch-itcl_class.c11
-rw-r--r--lang/itcl/files/patch-itcl_ensemble.c20
-rw-r--r--lang/itcl/files/patch-tests-ensemble.test11
4 files changed, 2 insertions, 44 deletions
diff --git a/lang/itcl/files/Makefile.lib b/lang/itcl/files/Makefile.lib
index 09b414b44173..c9fe57f90e05 100644
--- a/lang/itcl/files/Makefile.lib
+++ b/lang/itcl/files/Makefile.lib
@@ -2,7 +2,7 @@ NOPROFILE= yes
LIB= itcl${MAJOR}${MINOR}
ITCL_LIBRARY= ${PREFIX}/lib/itcl${MAJOR}.${MINOR}
CFLAGS+= -I. -I./../generic \
- -I${PREFIX}/include/tcl8.4/generic \
+ -I${PREFIX}/include/tcl8.3/generic \
-DHAVE_GETCWD=1 -DNO_VALUES_H=1 -DHAVE_UNISTD_H=1 -DUSE_TERMIOS=1\
-DHAVE_SYS_TIME_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_TM_ZONE=1\
-DHAVE_TM_GMTOFF=1 -DHAVE_ST_BLKSIZE=1 -DSTDC_HEADERS=1\
@@ -11,7 +11,7 @@ CFLAGS+= -I. -I./../generic \
-DHAVE_SYS_FILIO_H=1 \
-DRETSIGTYPE=void \
-DITCL_LIBRARY=\"${ITCL_LIBRARY}\"
-LDADD+= -L${PREFIX}/lib -ltcl84
+LDADD+= -L${PREFIX}/lib -ltcl83
.PATH: ${.CURDIR}/unix ${.CURDIR}/generic ${.CURDIR}/man
diff --git a/lang/itcl/files/patch-itcl_class.c b/lang/itcl/files/patch-itcl_class.c
deleted file mode 100644
index 0ccd8dabb726..000000000000
--- a/lang/itcl/files/patch-itcl_class.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- generic/itcl_class.c.orig Thu Oct 23 17:58:16 2003
-+++ generic/itcl_class.c Thu Oct 23 17:59:01 2003
-@@ -960,7 +960,7 @@
- * it--as it is being resolved again by the compiler.
- */
- cmdPtr = (Command*)mfunc->accessCmd;
-- if (!cmdPtr || cmdPtr->deleted) {
-+ if (!cmdPtr || (cmdPtr->flags & CMD_IS_DELETED)) {
- mfunc->accessCmd = NULL;
-
- if ((flags & TCL_LEAVE_ERR_MSG) != 0) {
diff --git a/lang/itcl/files/patch-itcl_ensemble.c b/lang/itcl/files/patch-itcl_ensemble.c
deleted file mode 100644
index dc5266a617c5..000000000000
--- a/lang/itcl/files/patch-itcl_ensemble.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- generic/itcl_ensemble.c.orig Thu Oct 23 17:59:33 2003
-+++ generic/itcl_ensemble.c Thu Oct 23 18:00:52 2003
-@@ -819,7 +819,7 @@
- cmdPtr->clientData = NULL;
- cmdPtr->deleteProc = DeleteEnsemble;
- cmdPtr->deleteData = cmdPtr->objClientData;
-- cmdPtr->deleted = 0;
-+ cmdPtr->flags = 0;
- cmdPtr->importRefPtr = NULL;
-
- ensPart->cmdPtr = cmdPtr;
-@@ -896,7 +896,7 @@
- cmdPtr->clientData = NULL;
- cmdPtr->deleteProc = deleteProc;
- cmdPtr->deleteData = (ClientData)clientData;
-- cmdPtr->deleted = 0;
-+ cmdPtr->flags = 0;
- cmdPtr->importRefPtr = NULL;
-
- ensPart->cmdPtr = cmdPtr;
diff --git a/lang/itcl/files/patch-tests-ensemble.test b/lang/itcl/files/patch-tests-ensemble.test
deleted file mode 100644
index 55d990d9278f..000000000000
--- a/lang/itcl/files/patch-tests-ensemble.test
+++ /dev/null
@@ -1,11 +0,0 @@
---- tests/ensemble.test.orig Fri Oct 24 20:00:39 2003
-+++ tests/ensemble.test Fri Oct 24 20:00:53 2003
-@@ -46,7 +46,7 @@
-
- test ensemble-1.5 {invoking parts with improper arguments} {
- list [catch "test_numbers three x" msg] $msg
--} {1 {no value given for parameter "y" to "test_numbers three"}}
-+} {1 {wrong # args: should be "test_numbers three x y z"}}
-
- test ensemble-1.6 {errors trigger a usage summary} {
- list [catch "test_numbers foo x y" msg] $msg