summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/pixieplus/Makefile8
-rw-r--r--graphics/pixieplus/distinfo1
-rw-r--r--graphics/pixieplus/files/patch-imageheaders.cpp11
3 files changed, 19 insertions, 1 deletions
diff --git a/graphics/pixieplus/Makefile b/graphics/pixieplus/Makefile
index e8242e6b2bb2..4e69cc6c2541 100644
--- a/graphics/pixieplus/Makefile
+++ b/graphics/pixieplus/Makefile
@@ -22,6 +22,12 @@ CONFIGURE_ARGS+= --program-prefix=''
USE_GMAKE= yes
USE_KDELIBS_VER=3
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
USE_LIBTOOL= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e 's@-lpthread@${PTHREAD_LIBS}@g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/graphics/pixieplus/distinfo b/graphics/pixieplus/distinfo
index 03cbb7385f4d..f3c8ea5099ae 100644
--- a/graphics/pixieplus/distinfo
+++ b/graphics/pixieplus/distinfo
@@ -1 +1,2 @@
MD5 (pixieplus-0.5.4.tar.gz) = a6296cdc53b5f1a38cd629f7591fef9e
+SIZE (pixieplus-0.5.4.tar.gz) = 2297945
diff --git a/graphics/pixieplus/files/patch-imageheaders.cpp b/graphics/pixieplus/files/patch-imageheaders.cpp
new file mode 100644
index 000000000000..4174d6806f5e
--- /dev/null
+++ b/graphics/pixieplus/files/patch-imageheaders.cpp
@@ -0,0 +1,11 @@
+--- app/imageheaders.cpp.orig Fri Jun 13 00:47:07 2003
++++ app/imageheaders.cpp Fri Jun 13 00:47:49 2003
+@@ -90,7 +90,7 @@
+ if(TIFFSetDirectory(t, thumbDir)){
+ TIFFGetField(t, TIFFTAG_IMAGELENGTH, &height);
+ img.create(minWidth, height, 32);
+- if(!TIFFReadRGBAImage(t, minWidth, height, (unsigned long*)
++ if(!TIFFReadRGBAImage(t, minWidth, height, (uint32*)
+ img.bits(), 0))
+ img.reset();
+ else{