summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cadubi/Makefile2
-rw-r--r--graphics/cbview/Makefile4
-rw-r--r--graphics/cthumb/Makefile4
-rw-r--r--graphics/icoutils/Makefile2
-rw-r--r--graphics/imc/Makefile4
-rw-r--r--graphics/orca/Makefile6
-rw-r--r--graphics/springgraph/Makefile2
7 files changed, 12 insertions, 12 deletions
diff --git a/graphics/cadubi/Makefile b/graphics/cadubi/Makefile
index be46f5cb543e..e00692c680f9 100644
--- a/graphics/cadubi/Makefile
+++ b/graphics/cadubi/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://langworth.com/pub/
MAINTAINER= ports@FreeBSD.org
COMMENT= ASCII drawing utility
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+RUN_DEPENDS= p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
USE_PERL5= yes
NO_BUILD= yes
diff --git a/graphics/cbview/Makefile b/graphics/cbview/Makefile
index 15ea385a6937..14720b3fe948 100644
--- a/graphics/cbview/Makefile
+++ b/graphics/cbview/Makefile
@@ -16,8 +16,8 @@ COMMENT= A viewer/converter for CBR/CBZ comic book archives
RUN_DEPENDS= unrar:${PORTSDIR}/archivers/unrar \
unzip:${PORTSDIR}/archivers/unzip \
- ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
- ${SITE_PERL}/String/ShellQuote.pm:${PORTSDIR}/textproc/p5-String-ShellQuote
+ p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ p5-String-ShellQuote>=0:${PORTSDIR}/textproc/p5-String-ShellQuote
NO_BUILD= yes
USE_PERL5= yes
diff --git a/graphics/cthumb/Makefile b/graphics/cthumb/Makefile
index b880c0d5e687..3f2dd0f78421 100644
--- a/graphics/cthumb/Makefile
+++ b/graphics/cthumb/Makefile
@@ -17,8 +17,8 @@ COMMENT= A themable web picture album generator
RUN_DEPENDS= ${LOCALBASE}/bin/pnmscale:${PORTSDIR}/graphics/netpbm \
${LOCALBASE}/bin/djpeg:${PORTSDIR}/graphics/jpeg \
${LOCALBASE}/bin/jhead:${PORTSDIR}/graphics/jhead \
- ${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-themedir=${DATADIR}
diff --git a/graphics/icoutils/Makefile b/graphics/icoutils/Makefile
index ceb358e6542c..687dd1c5315e 100644
--- a/graphics/icoutils/Makefile
+++ b/graphics/icoutils/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
USE_BZIP2= yes
USE_PERL5_RUN= yes
diff --git a/graphics/imc/Makefile b/graphics/imc/Makefile
index f67235e6abaa..90dd3cf360a6 100644
--- a/graphics/imc/Makefile
+++ b/graphics/imc/Makefile
@@ -15,8 +15,8 @@ MASTER_SITES= http://users.skynet.be/Peter.Verthez/projects/imc/
MAINTAINER= ports@FreeBSD.org
COMMENT= Image Compiler
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
- ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
+ p5-CGI.pm>=0:${PORTSDIR}/www/p5-CGI.pm
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
diff --git a/graphics/orca/Makefile b/graphics/orca/Makefile
index 4e8bf7bd9912..4b003eb7d220 100644
--- a/graphics/orca/Makefile
+++ b/graphics/orca/Makefile
@@ -16,9 +16,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Tool for plotting arbitrary data from text files onto a Web server
BUILD_DEPENDS= \
- ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
- ${SITE_PERL}/Math/Interpolate.pm:${PORTSDIR}/math/p5-Math-Interpolate \
- ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-Math-Interpolate>=0:${PORTSDIR}/math/p5-Math-Interpolate \
+ rrdtool>=0:${PORTSDIR}/databases/rrdtool
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --with-html-dir=${PREFIX}/www/data/orca
diff --git a/graphics/springgraph/Makefile b/graphics/springgraph/Makefile
index 72f8d6b974eb..14703df0c26b 100644
--- a/graphics/springgraph/Makefile
+++ b/graphics/springgraph/Makefile
@@ -17,7 +17,7 @@ EXTRACT_SUFX= .pl
MAINTAINER= ports@FreeBSD.org
COMMENT= Render graph described in a .dot file
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+RUN_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
CONFLICTS_INSTALL=signing-party-[0-9]*