summaryrefslogtreecommitdiff
path: root/graphics/xaralx/files/patch-configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xaralx/files/patch-configure.in')
-rw-r--r--graphics/xaralx/files/patch-configure.in62
1 files changed, 12 insertions, 50 deletions
diff --git a/graphics/xaralx/files/patch-configure.in b/graphics/xaralx/files/patch-configure.in
index 8d33883a5b64..932bd36803e7 100644
--- a/graphics/xaralx/files/patch-configure.in
+++ b/graphics/xaralx/files/patch-configure.in
@@ -1,45 +1,15 @@
---- configure.in.orig Wed May 10 14:01:21 2006
-+++ configure.in Wed May 10 14:04:32 2006
-@@ -47,7 +47,7 @@
- AC_PROG_INSTALL
- # We don't need dlopen right now and it's not supported on Darwin
- # AC_LIBTOOL_DLOPEN
--AC_PROG_LIBTOOL
-+AC_PROG_RANLIB
-
- AC_C_BIGENDIAN
- AC_CHECK_SIZEOF(void*)
-@@ -141,7 +141,6 @@
- if echo $WX_CPPFLAGS | grep -q '__WXGTK__' ; then
- WX_GTK="yes"
- AC_MSG_RESULT([found])
-- PKG_CHECK_MODULES(GTK, [gtk+-2.0])
- else
- AC_MSG_RESULT([not found])
- fi
-@@ -215,20 +214,7 @@
- # GTK build, so call FTTEST function to test for FreeType
- FTTEST
- FT_CFLAGS="`$FTCONFIG --cflags`"
--
-- # check for the Pango package
-- PkgError="no"
-- PKG_CHECK_MODULES(PANGOX, pangox,
-- [
-- PANGO_CFLAGS="$PANGOX_CFLAGS"
-- ],
-- [
-- PkgError="yes"
-- ]
-- )
-- if test PkgError = "yes"; then
-- AC_MSG_ERROR([pangox library not found])
-- fi
-+ PANGO_CFLAGS=""
- else
- # non-GTK build, i.e., MacOS, so Pango and FreeType are not required
- FT_CFLAGS=""
-@@ -246,8 +232,8 @@
+--- configure.in.orig Mon Jun 5 15:06:26 2006
++++ configure.in Mon Jun 5 15:07:19 2006
+@@ -139,7 +139,7 @@
+ WX_CPPFLAGS="`$WXCONFIG --static=$StaticEnable --debug=$DebugEnable --unicode=yes --cppflags`"
+ WX_CXXFLAGS="`$WXCONFIG --static=$StaticEnable --debug=$DebugEnable --unicode=yes --cxxflags | sed -e 's/-fno-exceptions//'`"
+ WX_LIBS="`$WXCONFIG --static=$StaticEnable --debug=$DebugEnable --unicode=yes --libs`"
+- WXRC="`$WXCONFIG --utility=wxrc`"
++ WXRC="`$WXCONFIG --utility=wxrc-gtk2u`"
+
+ # See if we are running on GTK
+ WX_GTK="no"
+@@ -252,8 +252,8 @@
fi
# pass the Pango, FreeType and GTK flags (required for wxGTK font rendering)
@@ -50,11 +20,3 @@
AC_MSG_CHECKING([Linker])
case $host in
-@@ -286,6 +272,7 @@
- AM_CONDITIONAL(DARWIN_LINK, [test "$DarwinLink" = "yes"])
-
- AC_SUBST(TOPDIR)
-+AC_SUBST(WX_CPPFLAGS)
- AC_SUBST(WX_LIBS)
- AC_SUBST(XRCINCLUDE)
- AC_SUBST(XARALANGUAGE)