summaryrefslogtreecommitdiff
path: root/graphics/povray/files
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/povray/files')
-rw-r--r--graphics/povray/files/patch-Makefile.in56
-rw-r--r--graphics/povray/files/patch-povray.ini13
-rw-r--r--graphics/povray/files/patch-src::Makefile.in34
-rw-r--r--graphics/povray/files/patch-src::frame.h23
-rw-r--r--graphics/povray/files/patch-src::optin.cpp11
-rw-r--r--graphics/povray/files/patch-src::optout.h12
6 files changed, 0 insertions, 149 deletions
diff --git a/graphics/povray/files/patch-Makefile.in b/graphics/povray/files/patch-Makefile.in
deleted file mode 100644
index 8bfd60f4ba01..000000000000
--- a/graphics/povray/files/patch-Makefile.in
+++ /dev/null
@@ -1,56 +0,0 @@
---- Makefile.in.orig Tue Oct 22 09:54:06 2002
-+++ Makefile.in Sun Nov 17 23:56:45 2002
-@@ -90,6 +90,7 @@
-
- povlibdir = @datadir@/povray-3.5
- SUBDIRS = doc include ini scenes scripts src tests
-+SUBDIRS_DATA = include ini scenes scripts src tests
- docdir = ${datadir}/doc/@PACKAGE@-@VERSION@
- doc_DATA = povlegal.doc povwhere.txt gamma.gif gamma.gif.txt README README.unix
- povconfdir = @sysconfdir@
-@@ -101,7 +102,7 @@
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ./src/conf.h
- CONFIG_CLEAN_FILES =
--DATA = $(doc_DATA) $(sysconf_DATA)
-+DATA = $(doc_DATA) #$(sysconf_DATA)
-
- DIST_COMMON = README AUTHORS COPYING ChangeLog INSTALL Makefile.am \
- Makefile.in NEWS aclocal.m4 configure configure.in install-sh missing \
-@@ -204,7 +205,26 @@
-
- @SET_MAKE@
-
--all-recursive install-data-recursive install-exec-recursive \
-+install-data-recursive:
-+ @set fnord $(MAKEFLAGS); amf=$$2; \
-+ dot_seen=no; \
-+ target=`echo $@ | sed s/-recursive//`; \
-+ list='$(SUBDIRS_DATA)'; for subdir in $$list; do \
-+ echo "Making $$target in $$subdir"; \
-+ if test "$$subdir" = "."; then \
-+ dot_seen=yes; \
-+ local_target="$$target-am"; \
-+ else \
-+ local_target="$$target"; \
-+ fi; \
-+ (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
-+ || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
-+ done; \
-+ if test "$$dot_seen" = "no"; then \
-+ $(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
-+ fi; test -z "$$fail"
-+
-+all-recursive install-exec-recursive \
- installdirs-recursive install-recursive uninstall-recursive \
- check-recursive installcheck-recursive info-recursive dvi-recursive:
- @set fnord $(MAKEFLAGS); amf=$$2; \
-@@ -353,7 +373,7 @@
- install-exec-am: install-sysconfDATA
- install-exec: install-exec-recursive
-
--install-data-am: install-docDATA
-+install-data-am: #install-docDATA
- install-data: install-data-recursive
-
- install-am: all-am
diff --git a/graphics/povray/files/patch-povray.ini b/graphics/povray/files/patch-povray.ini
deleted file mode 100644
index 4d38fb28ef7f..000000000000
--- a/graphics/povray/files/patch-povray.ini
+++ /dev/null
@@ -1,13 +0,0 @@
---- povray.ini.orig Tue Oct 22 09:54:06 2002
-+++ povray.ini Mon Nov 18 00:00:35 2002
-@@ -55,8 +55,8 @@
- ;; found in the current directory. New directories are added to the
- ;; search path, up to a maximum of 25.
-
--Library_Path=/usr/local/share/povray-3.5
--Library_Path=/usr/local/share/povray-3.5/include
-+Library_Path=@PREFIX@/share/povray-3.5
-+Library_Path=@PREFIX@/share/povray-3.5/include
-
- ;; File output type control.
- ;; T Uncompressed Targa-24
diff --git a/graphics/povray/files/patch-src::Makefile.in b/graphics/povray/files/patch-src::Makefile.in
deleted file mode 100644
index f063d7529c8d..000000000000
--- a/graphics/povray/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/Makefile.in.orig Tue Jan 7 10:23:23 2003
-+++ src/Makefile.in Sat Apr 12 08:56:01 2003
-@@ -92,8 +92,10 @@
- DEFS = -DPREFIX=\"$(prefix)\" -DPOV_LIB_DIR=\"@datadir@/povray-3.5\" -DCOMPILER_VER=\".Linux.$(CC)\" -DSYSCONFDIR=\"$(sysconfdir)\" -DUSE_IO_RESTRICTIONS=\"$(ac_use_io_restrictions)\"
- NOMULTICHAR = `if [ "X$(CC)" = "Xgcc" ]; then echo "-Wno-multichar"; fi `
- LDADD = @X_LIBS@
--CFLAGS = -O3 -mcpu=i586 -march=i586 -finline-functions -ffast-math -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -foptimize-sibling-calls -minline-all-stringops -Wno-multichar
--CXXFLAGS = $(NOMULTICHAR) -O3 -finline-functions -ffast-math -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -foptimize-sibling-calls -minline-all-stringops -Wno-multichar
-+#CFLAGS = -O3 -mcpu=i586 -march=i586 -finline-functions -ffast-math -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -foptimize-sibling-calls -minline-all-stringops -Wno-multichar
-+#CXXFLAGS = $(NOMULTICHAR) -O3 -finline-functions -ffast-math -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -foptimize-sibling-calls -minline-all-stringops -Wno-multichar
-+CFLAGS = @CFLAGS@
-+CXXFLAGS = @CXXFLAGS@
- LDFLAGS = @X_CFLAGS@
- EXTRA_DIST = xpovicon.xbm xpovmask.xbm xpovicon.xpm
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
-@@ -102,7 +104,7 @@
- PROGRAMS = $(bin_PROGRAMS)
-
- CPPFLAGS = @CPPFLAGS@
--LIBS = @LIBS@
-+LIBS = -L${LOCALBASE}/lib @LIBS@
- X_CFLAGS = @X_CFLAGS@
- X_LIBS = @X_LIBS@
- X_EXTRA_LIBS = @X_EXTRA_LIBS@
-@@ -123,7 +125,8 @@
- vlbuffer.o warps.o unix.o povxlib.o
- povray_LDADD = $(LDADD)
- povray_DEPENDENCIES =
--povray_LDFLAGS =
-+povray_LDFLAGS = -L$(libdir)
-+INCLUDES = -I$(includedir) $(X_CFLAGS)
- CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
- CXXLD = $(CXX)
- CXXLINK = $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@
diff --git a/graphics/povray/files/patch-src::frame.h b/graphics/povray/files/patch-src::frame.h
deleted file mode 100644
index 296d46b51cab..000000000000
--- a/graphics/povray/files/patch-src::frame.h
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/frame.h.orig Tue Jan 7 10:08:30 2003
-+++ src/frame.h Sun Dec 28 23:37:04 2003
-@@ -44,12 +44,20 @@
- class pov_istream_class;
- class pov_ostream_class;
-
-+#if defined(__LP64__) || defined(__alpha__)
-+typedef unsigned int u_int32 ;
-+#else
- typedef unsigned long u_int32 ;
-+#endif
- typedef unsigned short u_int16 ;
- typedef unsigned char u_int8 ;
- typedef unsigned char byte ;
-
-+#if defined(__LP64__) || defined(__alpha__)
-+typedef signed int int32 ;
-+#else
- typedef signed long int32 ;
-+#endif
- typedef signed short int16 ;
- typedef signed char int8 ;
-
diff --git a/graphics/povray/files/patch-src::optin.cpp b/graphics/povray/files/patch-src::optin.cpp
deleted file mode 100644
index 861253a79145..000000000000
--- a/graphics/povray/files/patch-src::optin.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/optin.cpp.orig Sun Dec 28 23:43:15 2003
-+++ src/optin.cpp Sun Dec 28 23:43:52 2003
-@@ -364,7 +364,7 @@
-
- static bool matches(char *v1, char *v2);
-
--POV_ISTREAM *Opts_Locate_File(char *filename, unsigned long stype, char *buffer, int err_flag, POVMSObjectPtr obj);
-+POV_ISTREAM *Opts_Locate_File(char *filename, u_int32 stype, char *buffer, int err_flag, POVMSObjectPtr obj);
-
-
- /*****************************************************************************
diff --git a/graphics/povray/files/patch-src::optout.h b/graphics/povray/files/patch-src::optout.h
deleted file mode 100644
index 4ef0ede6c180..000000000000
--- a/graphics/povray/files/patch-src::optout.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/optout.h.orig Thu Aug 8 22:00:48 2002
-+++ src/optout.h Wed Aug 14 12:14:50 2002
-@@ -46,8 +46,7 @@
- #define OFFICIAL_VERSION_NUMBER 350
-
- #define DISTRIBUTION_MESSAGE_1 "This is an unofficial version compiled by:"
--#error You must complete the following DISTRIBUTION_MESSAGE macro
--#define DISTRIBUTION_MESSAGE_2 " FILL IN NAME HERE........................."
-+#define DISTRIBUTION_MESSAGE_2 "FreeBSD, http://www.freebsd.org/"
- #define DISTRIBUTION_MESSAGE_3 " The POV-Ray Team(tm) is not responsible for supporting this version."
-
- /* Number of help pages (numbered 0 to MAX_HELP_PAGE). */