summaryrefslogtreecommitdiff
path: root/graphics/pixieplus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/pixieplus/Makefile')
-rw-r--r--graphics/pixieplus/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/pixieplus/Makefile b/graphics/pixieplus/Makefile
index e8242e6b2bb2..4e69cc6c2541 100644
--- a/graphics/pixieplus/Makefile
+++ b/graphics/pixieplus/Makefile
@@ -22,6 +22,12 @@ CONFIGURE_ARGS+= --program-prefix=''
USE_GMAKE= yes
USE_KDELIBS_VER=3
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
USE_LIBTOOL= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e 's@-lpthread@${PTHREAD_LIBS}@g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>