summaryrefslogtreecommitdiff
path: root/graphics/netpbm/files/patch-lib-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/netpbm/files/patch-lib-Makefile')
-rw-r--r--graphics/netpbm/files/patch-lib-Makefile97
1 files changed, 97 insertions, 0 deletions
diff --git a/graphics/netpbm/files/patch-lib-Makefile b/graphics/netpbm/files/patch-lib-Makefile
new file mode 100644
index 000000000000..2b480b273929
--- /dev/null
+++ b/graphics/netpbm/files/patch-lib-Makefile
@@ -0,0 +1,97 @@
+--- lib/Makefile.orig Thu Sep 25 18:23:47 2003
++++ lib/Makefile Mon Dec 1 14:28:48 2003
+@@ -32,12 +32,14 @@
+ # Library objects to be linked but not built by Makefile.common:
+ LIBOBJECTS_X = util/shhopt.o util/nstring.o
+
++SHLIBOBJECTS = $(patsubst %.o, %.lo, $(LIBOBJECTS))
++
+ MANUALS3 = libnetpbm
+ MANUALS5 = pbm pgm ppm pnm pam
+
+ INTERFACE_HEADERS = pm.h pbm.h bitio.h pbmfont.h \
+ pgm.h ppm.h ppm.h ppmcmap.h ppmfloyd.h colorname.h \
+ pnm.h pam.h pammap.h util/shhopt.h util/nstring.h util/mallocvar.h
+
+ DATAFILES = rgb.txt
+
+@@ -71,12 +71,15 @@
+
+ $(LIBOBJECTS): %.o: %.c $(HEADERLINKS)
+ # Note that the user may have configured -I options into CFLAGS.
++ $(CC) -c $(INCLUDES) $(CFLAGS) $(CADD) -o $@ $<
++
++$(SHLIBOBJECTS): %.lo: %.c $(HEADERLINKS)
+ $(CC) -c $(INCLUDES) $(CFLAGS) $(CFLAGS_SHLIB) $(CADD) -o $@ $<
+
+ MAJ = $(NETPBM_MAJOR_RELEASE)
+ MIN = $(NETPBM_MINOR_RELEASE)
+
+-SONAME = libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ)
++SONAME = libnetpbm.$(NETPBMLIBSUFFIX).$(SOVER)
+
+ ifeq ($(NETPBMLIBTYPE),irixshared)
+ # The libxxx.so link is needed to link the executables.
+@@ -101,11 +104,8 @@
+ # The $(SONAME) link is needed only to test the programs without
+ # installing the libraries (in that case, you also need to direct the
+ # dynamic linker to the source directories, e.g. set LD_LIBRARY_PATH).
+-$(SONAME): libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).$(MIN)
+- rm -f $@
+- $(SYMLINK) $< $@
+-libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).$(MIN): $(LIBOBJECTS) $(LIBOBJECTS_X)
+- $(LD) $(LDSHLIB) -o $@ $(LIBOBJECTS) $(LIBOBJECTS_X) \
++$(SONAME): $(SHLIBOBJECTS) $(LIBOBJECTS_X)
++ $(LD) $(LDSHLIB) -o $@ $(SHLIBOBJECTS) $(LIBOBJECTS_X) \
+ $(SHLIB_CLIB) $(LADD)
+ endif
+
+@@ -183,13 +183,10 @@
+ .PHONY: install.lib
+ ifeq ($(NETPBMLIBTYPE),unixshared)
+ # install a Unix-style shared library
+-install.lib: $(PKGDIR)/lib $(PKGDIR)/link
+- cd $(PKGDIR)/lib ; rm -f libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).*
+- $(INSTALL) -c -m $(INSTALL_PERM_LIBD) \
+- libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).$(MIN) $(PKGDIR)/lib/
+- cd $(PKGDIR)/lib/ ; \
+- rm -f libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ); \
+- $(SYMLINK) libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).$(MIN) $(SONAME)
++install.lib: $(PKGDIR)/lib
++ cd $(PKGDIR)/lib ; rm -f libnetpbm.$(NETPBMLIBSUFFIX).*
++ ${BSD_INSTALL_DATA} \
++ $(SONAME) $(PKGDIR)/lib/
+ endif
+ ifeq ($(NETPBMLIBTYPE),dll)
+ #install a Windows DLL shared library
+@@ -219,23 +216,23 @@
+ # directory when you compile your programs.
+
+ %_installhdr: $(PKGDIR)/include
+- $(INSTALL) -c -m $(INSTALL_PERM_HDR) \
++ ${BSD_INSTALL_DATA} \
+ $(SRCDIR)/lib/$(@:%_installhdr=%) $(PKGDIR)/include/;
+
+ .PHONY: install.staticlib
+-install.staticlib: $(PKGDIR)/link
+- $(INSTALL) -c -m $(INSTALL_PERM_LIBS) libnetpbm.$(STATICLIBSUFFIX) \
+- $(PKGDIR)/link
++install.staticlib: $(PKGDIR)/lib
++ ${BSD_INSTALL_DATA} libnetpbm.$(STATICLIBSUFFIX) \
++ $(PKGDIR)/lib
+
+ # Install a shared library stub -- the ".so" file used at link time to
+ # prepare a program for dynamically linking a library at run time
+ .PHONY: install.sharedlibstub
+-install.sharedlibstub: $(PKGDIR)/link
++install.sharedlibstub: $(PKGDIR)/lib
+ ifeq ($(NETPBMLIBTYPE),unixshared)
+ # install the link-time (.so) links to the runtime libraries
+- cd $(PKGDIR)/link ; \
++ cd $(PKGDIR)/lib ; \
+ rm -f libnetpbm.$(NETPBMLIBSUFFIX); \
+- $(SYMLINK) ../lib/libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ) \
++ $(SYMLINK) $(SONAME) \
+ libnetpbm.$(NETPBMLIBSUFFIX)
+ endif
+ ifeq ($(NETPBMLIBTYPE),dll)