summaryrefslogtreecommitdiff
path: root/graphics/hs-cairo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/hs-cairo/Makefile')
-rw-r--r--graphics/hs-cairo/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/graphics/hs-cairo/Makefile b/graphics/hs-cairo/Makefile
new file mode 100644
index 000000000000..9abe098a9a54
--- /dev/null
+++ b/graphics/hs-cairo/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: hs-cairo
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cairo
+PORTVERSION= 0.12.0
+CATEGORIES= graphics haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Binding to the Cairo library
+
+LICENSE= BSD
+FILE_LICENSE= COPYRIGHT
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= gtk2hs-buildtools mtl
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/cairo-pdf.pc:${PORTSDIR}/graphics/cairo
+
+PORTDATA= *
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>