summaryrefslogtreecommitdiff
path: root/graphics/guilib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/guilib/Makefile')
-rw-r--r--graphics/guilib/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/guilib/Makefile b/graphics/guilib/Makefile
index 3539c9b640fb..da600bd1493b 100644
--- a/graphics/guilib/Makefile
+++ b/graphics/guilib/Makefile
@@ -17,8 +17,13 @@ COMMENT= A very simple GUI framework for use with SDL
USE_SDL= sdl
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
-LIBTOOLFLAGS= --disable-ltlibs --release-ignore
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-release $$(LT_RELEASE)||g' ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>