summaryrefslogtreecommitdiff
path: root/graphics/gqview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gqview/Makefile')
-rw-r--r--graphics/gqview/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/graphics/gqview/Makefile b/graphics/gqview/Makefile
index eac91839cf03..15294eb50140 100644
--- a/graphics/gqview/Makefile
+++ b/graphics/gqview/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gqview
-PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTVERSION= 2.0.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,12 +18,15 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_X_PREFIX= yes
USE_GNOME= gnomehier gtk20
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= gqview.1
+CONFLICTS= gqview-devel-[0-9]*
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
@@ -33,6 +35,17 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+.if !defined(NOPORTDOCS)
+PORTDOCS= README html
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$prefix/share/doc/gqview-$$VERSION|${DOCSDIR}|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|$$(datadir)/doc/gqview-$$(VERSION)/html|${DOCSDIR}/html|g' \
+ ${WRKSRC}/doc/Makefile.in
+
post-install:
${INSTALL_DATA} ${WRKSRC}/gqview.desktop ${PREFIX}/share/gnome/apps/Graphics
${INSTALL_DATA} ${WRKSRC}/gqview.png ${PREFIX}/share/gnome/pixmaps