summaryrefslogtreecommitdiff
path: root/graphics/gnash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gnash/Makefile')
-rw-r--r--graphics/gnash/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 9777fba53db1..f2f201ff790d 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -34,14 +34,14 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -Wl,--rpath,${PREFIX}/lib/gnash"
CONFIGURE_ARGS= --libdir="${PREFIX}/lib/gnash" \
--with-plugindir=${PLUGIN_DIR}
-.if ${MACHINE_ARCH:L} == "amd64"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
OPTIONS= PLUGIN "Enable firefox plugin" on
.else
OPTIONS= PLUGIN "Enable firefox plugin" off
.endif
-.include <bsd.port.pre.mk>
-
.if !defined(WITH_PLUGIN)
CONFIGURE_ARGS+= --disable-plugin
PLIST_SUB+= PLUGIN="@comment "