summaryrefslogtreecommitdiff
path: root/graphics/eog-plugins/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--graphics/eog-plugins/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/graphics/eog-plugins/Makefile b/graphics/eog-plugins/Makefile
index fe68490b16a3..9fed45c5dd5e 100644
--- a/graphics/eog-plugins/Makefile
+++ b/graphics/eog-plugins/Makefile
@@ -3,11 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/graphics/eog-plugins/Makefile,v 1.1 2010/06/23 15:28:22 kwm Exp $
+# $MCom: ports/graphics/eog-plugins/Makefile,v 1.14 2010/09/04 18:09:30 kwm Exp $
#
PORTNAME= eog-plugins
PORTVERSION= 2.30.1
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -31,8 +32,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_CHAMPLAIN) || \
- (exists(${LOCALBASE}/lib/libchamplain-0.4.so)) || defined(WITH_CHAMPLIAN)
-LIB_DEPENDS+= champlain-0.4.1:${PORTSDIR}/graphics/libchamplain
+ (exists(${LOCALBASE}/lib/libchamplain-0.8.so)) || defined(WITH_CHAMPLIAN)
+LIB_DEPENDS+= champlain-0.8.1:${PORTSDIR}/graphics/libchamplain
PLIST_SUB+= CHAMPLAIN=""
.else
PLUST_SUB+= CHAMPLAIN="@comment "
@@ -55,4 +56,9 @@ CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|champlain-0.4|champlain-0.8|g' \
+ -e 's|champlain-gtk-0.4|champlain-gtk-0.8|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>