summaryrefslogtreecommitdiff
path: root/graphics/comix
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/comix')
-rw-r--r--graphics/comix/Makefile47
-rw-r--r--graphics/comix/distinfo3
-rw-r--r--graphics/comix/pkg-descr5
-rw-r--r--graphics/comix/pkg-plist8
4 files changed, 63 insertions, 0 deletions
diff --git a/graphics/comix/Makefile b/graphics/comix/Makefile
new file mode 100644
index 000000000000..d77f1d14771f
--- /dev/null
+++ b/graphics/comix/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: comix
+# Date created: 26 November 2005
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= comix
+PORTVERSION= 2.2
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= A GTK2 comic book viewer for .cbz, .cbr and .cbt files
+
+RUN_DEPENDS= unrar:${PORTSDIR}/archivers/unrar
+
+NO_BUILD= yes
+USE_GNOME= pygtk2
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+DOCS= COPYING ChangeLog README
+MAN1= comix.1
+
+post-extract:
+ @${GUNZIP_CMD} ${WRKSRC}/comix.1.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/man|man|g ; s|1.gz|1|g' \
+ ${WRKSRC}/install.py
+
+do-install:
+ @(cd ${WRKSRC} ; \
+ ${PYTHON_CMD} install.py install --installdir ${PREFIX})
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/comix/distinfo b/graphics/comix/distinfo
new file mode 100644
index 000000000000..bb06c376b9da
--- /dev/null
+++ b/graphics/comix/distinfo
@@ -0,0 +1,3 @@
+MD5 (comix-2.2.tar.gz) = b94bdcbf2d5a542f470a67806d704608
+SHA256 (comix-2.2.tar.gz) = ca4110c41f3b8f59a63aa4961f0c81adde152e822e0e23713c3d6f236005b51d
+SIZE (comix-2.2.tar.gz) = 44646
diff --git a/graphics/comix/pkg-descr b/graphics/comix/pkg-descr
new file mode 100644
index 000000000000..72951b6a3ca9
--- /dev/null
+++ b/graphics/comix/pkg-descr
@@ -0,0 +1,5 @@
+Comix is an image viewer specifically designed to handle comic books. It reads
+ZIP, RAR and tar archives (also gzip or bzip2 compressed), as well as plain
+image files. It has a simple and user-friendly GUI using PyGTK.
+
+WWW: http://comix.sourceforge.net/
diff --git a/graphics/comix/pkg-plist b/graphics/comix/pkg-plist
new file mode 100644
index 000000000000..81eef3b1d0c8
--- /dev/null
+++ b/graphics/comix/pkg-plist
@@ -0,0 +1,8 @@
+bin/comix
+share/applications/comix.desktop
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/pixmaps/comix.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rmdir %D/share/applications 2> /dev/null || true