summaryrefslogtreecommitdiff
path: root/games/xboard
diff options
context:
space:
mode:
Diffstat (limited to 'games/xboard')
-rw-r--r--games/xboard/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/xboard/Makefile b/games/xboard/Makefile
index f6a22f58163e..c4f2cd5a82e5 100644
--- a/games/xboard/Makefile
+++ b/games/xboard/Makefile
@@ -17,11 +17,17 @@ COMMENT= X frontend for Crafty, GNUChess, Internet Chess Servers, or e-mail ches
USE_XLIB= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
STRIP=
MAN6= xboard.6 cmail.6 zic2xpm.6
+.if defined(WITH_XAW3D)
+ONFIGURE_ARGS+= "--with-Xaw3d"
+LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+.endif
+
pre-patch:
- @${PERL} -pi.orig -e 's|\$$\(prefix\)/share/info|\@infodir\@|' \
+ @${REINPLACE_CMD} -e 's,$$(prefix)/share/info,@infodir@,' \
${WRKSRC}/Makefile.in
.include <bsd.port.mk>