summaryrefslogtreecommitdiff
path: root/games/redeclipse16/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/redeclipse16/files')
-rw-r--r--games/redeclipse16/files/patch-config_setup.cfg29
-rw-r--r--games/redeclipse16/files/patch-src_Makefile13
-rw-r--r--games/redeclipse16/files/redeclipse.in3
-rw-r--r--games/redeclipse16/files/redeclipse_server.in3
4 files changed, 48 insertions, 0 deletions
diff --git a/games/redeclipse16/files/patch-config_setup.cfg b/games/redeclipse16/files/patch-config_setup.cfg
new file mode 100644
index 000000000000..4f8ad12418d3
--- /dev/null
+++ b/games/redeclipse16/files/patch-config_setup.cfg
@@ -0,0 +1,29 @@
+Upstream commits ec1e32e1410f51c336e893ecfb56f728fdcc1a92,
+bb4b6862f802c040ef67484942e91f7c3d88e649: fix hiding HUD
+permanently when HUDless screenshot is taken.
+diff --git config/setup.cfg config/setup.cfg
+index 4edcf170..e6888f81 100644
+--- config/setup.cfg
++++ config/setup.cfg
+@@ -316,9 +316,19 @@ dobindsearch = [
+ [search@[arg2]binds] $arg1 5 "^f{" "}" (? $textkeyseps (? $textkeyimages "|" ", ") (? $textkeyimages "" " ")) (? $textkeyseps (? $textkeyimages "|" " or ") (? $textkeyimages "" " "))
+ ]
+
++// screenshotnohud: Takes a screenshot without a hud
++// The screenshot and the hud showing are delayed to prevent any issues since
++// the game skips a few frames while taking a screenshot.
++canscreenshotnohud = 1
+ screenshotnohud = [
+- sleep 50 [ screenshot; showhud @showhud ]
+- showhud 0
++ if $canscreenshotnohud [
++ canscreenshotnohud = 0 // Lock screenshotting without a hud for the 50ms duration
++ hudwasshown = $showhud // Previous $showhud state
++ if $hudwasshown [showhud 0] // Hide hud if it was shown
++ sleep 25 [screenshot]
++ // Restore hud if it was shown and restore screenshotting.
++ sleep 50 [showhud $hudwasshown; canscreenshotnohud = 1]
++ ]
+ ]
+
+ listcomplete vdelta [
diff --git a/games/redeclipse16/files/patch-src_Makefile b/games/redeclipse16/files/patch-src_Makefile
new file mode 100644
index 000000000000..95c5dfa2c78b
--- /dev/null
+++ b/games/redeclipse16/files/patch-src_Makefile
@@ -0,0 +1,13 @@
+--- src/Makefile.orig 2016-06-30 04:34:23 UTC
++++ src/Makefile
+@@ -82,8 +82,8 @@ else
+ BIN_SUFFIX=_native
+ endif
+ endif
+-CLIENT_INCLUDES= $(INCLUDES) -I/usr/X11R6/include `sdl2-config --cflags`
+-CLIENT_LIBS= -Lenet -lenet -L/usr/X11R6/lib -lX11 `sdl2-config --libs` -lSDL2_image -lSDL2_mixer -lz -lGL
++CLIENT_INCLUDES= $(INCLUDES) -I${LOCALBASE}/include `sdl2-config --cflags`
++CLIENT_LIBS= -Lenet -lenet -L${LOCALBASE}/lib -lX11 `sdl2-config --libs` -lSDL2_image -lSDL2_mixer -lz -lGL
+ endif
+ ifneq (,$(findstring linux,$(PLATFORM)))
+ CLIENT_LIBS+= -lrt
diff --git a/games/redeclipse16/files/redeclipse.in b/games/redeclipse16/files/redeclipse.in
new file mode 100644
index 000000000000..5e85841d7f38
--- /dev/null
+++ b/games/redeclipse16/files/redeclipse.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/redeclipse "$@"
diff --git a/games/redeclipse16/files/redeclipse_server.in b/games/redeclipse16/files/redeclipse_server.in
new file mode 100644
index 000000000000..97aa8ccf3779
--- /dev/null
+++ b/games/redeclipse16/files/redeclipse_server.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%% && exec %%PREFIX%%/libexec/redeclipse_server "$@"