summaryrefslogtreecommitdiff
path: root/games/chanta/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/chanta/Makefile')
-rw-r--r--games/chanta/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/games/chanta/Makefile b/games/chanta/Makefile
index c2d0cbbfd42d..3504ea35bb0a 100644
--- a/games/chanta/Makefile
+++ b/games/chanta/Makefile
@@ -7,6 +7,7 @@
PORTNAME= chanta
PORTVERSION= 0.15
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.losersjuegos.com.ar/juegos/chanta/descargas/
@@ -24,12 +25,8 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CHANTADIRS= data ima
-post-extract:
- @${FIND} -E ${WRKSRC}/src/ -type f -iregex ".*\.(cpp|h)" \
- -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's/<SDL/<SDL11/'
-
post-configure:
- @${REINPLACE_CMD} -e 's|-lSDL |`sdl11-config --libs` |g' ${WRKSRC}/src/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's|-lSDL |`sdl-config --libs` |g' ${WRKSRC}/src/${MAKEFILE}
@${REINPLACE_CMD} -e 's|^CXXFLAGS|^CXXFLAGS?|g' ${WRKSRC}/src/${MAKEFILE}
do-install: