summaryrefslogtreecommitdiff
path: root/ftp/ftpcube/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/ftpcube/Makefile')
-rw-r--r--ftp/ftpcube/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/ftp/ftpcube/Makefile b/ftp/ftpcube/Makefile
new file mode 100644
index 000000000000..4a5f60058585
--- /dev/null
+++ b/ftp/ftpcube/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: ftpcube
+# Date created: Dec 13, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftpcube
+PORTVERSION= 0.1.1
+CATEGORIES= ftp python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk.py:${PORTSDIR}/x11-toolkits/py-gtk
+
+USE_PYTHON= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.include <bsd.port.mk>