summaryrefslogtreecommitdiff
path: root/editors/openoffice.org-3-RC
diff options
context:
space:
mode:
Diffstat (limited to 'editors/openoffice.org-3-RC')
-rw-r--r--editors/openoffice.org-3-RC/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index ad1c402a4e27..d58405171788 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -50,6 +50,7 @@ USE_GMAKE= yes
USE_PERL5= yes
USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
+MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
@@ -135,8 +136,10 @@ GNU_CONFIGURE= yes
WRKSRC?= ${WRKDIR}/${OOOTAG}
TCSH?= /bin/tcsh
PKGMESSAGE= ${WRKDIR}/pkg-message
-MAXPROCESSES?= 1
-MAXMODULES?= 1
+
+.if defined(DISABLE_MAKE_JOBS)
+MAKE_JOBS_NUMBER= 1
+.endif
CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp \
--with-gnu-patch=${LOCALBASE}/bin/gpatch \
@@ -202,7 +205,7 @@ pre-configure:
do-build:
@cd ${WRKSRC} ; ./bootstrap
- @cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" "TMP=${WRKSRC}" ${TCSH} -c "source ${FREEBSD_ENV_SET} ; cd instsetoo_native ; build.pl --checkmodules ; build.pl -P${MAXMODULES} --all --html --dontgraboutput -- -P${MAXPROCESSES}"
+ @cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" "TMP=${WRKSRC}" ${TCSH} -c "source ${FREEBSD_ENV_SET} ; cd instsetoo_native ; build.pl --checkmodules ; build.pl -P${MAKE_JOBS_NUMBER} --all --html --dontgraboutput -- -P${MAKE_JOBS_NUMBER}"
.if ${LOCALIZED_LANG} == "alllangs"
@${MAKE} languagepack