summaryrefslogtreecommitdiff
path: root/editors/gedit2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/gedit2/Makefile')
-rw-r--r--editors/gedit2/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/editors/gedit2/Makefile b/editors/gedit2/Makefile
index c7aa77b91271..29665770ba14 100644
--- a/editors/gedit2/Makefile
+++ b/editors/gedit2/Makefile
@@ -6,29 +6,30 @@
#
PORTNAME= gedit2
-PORTVERSION= 2.2.2
+PORTVERSION= 2.4.0
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
DISTNAME= gedit-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A small but powerful text editor for Gnome 2.0 Desktop Environment
+COMMENT= A small but powerful text editor for Gnome 2 Desktop Environment
LIB_DEPENDS= pspell.15:${PORTSDIR}/textproc/aspell
-WRKSRC= ${WRKDIR}/gedit-${PORTVERSION}
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeprintui eel2
+USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeprintui libgnomeui \
+ eel2 gtksourceview
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_SUB= VERSION="2.4"
-MAN1= gedit.1
+MAN1= gedit.1
.include <bsd.port.mk>