summaryrefslogtreecommitdiff
path: root/editors/emacs21/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/emacs21/Makefile')
-rw-r--r--editors/emacs21/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/editors/emacs21/Makefile b/editors/emacs21/Makefile
index 6cbb0961c5c4..9e3c514e365f 100644
--- a/editors/emacs21/Makefile
+++ b/editors/emacs21/Makefile
@@ -32,7 +32,6 @@ PATCH_DIST_STRIP= -p1
USE_AUTOCONF_VER=213
USE_GMAKE= yes
-ALL_TARGET= bootstrap
CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
.if defined(WITHOUT_X11)
@@ -67,6 +66,13 @@ post-patch:
${RM} $${f}.texi.orig ; \
done)
+post-build:
+ (cd ${WRKSRC}/lisp ; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} recompile ; \
+ ${RM} ${WRKSRC}/src/emacs ${WRKSRC}/src/emacs-${PORTVERSION}.1 ; \
+ cd ${WRKSRC}/src ; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+
post-install:
@${CAT} ${PKGMESSAGE}