summaryrefslogtreecommitdiff
path: root/editors/doxymacs
diff options
context:
space:
mode:
Diffstat (limited to 'editors/doxymacs')
-rw-r--r--editors/doxymacs/Makefile24
-rw-r--r--editors/doxymacs/distinfo1
-rw-r--r--editors/doxymacs/pkg-descr15
-rw-r--r--editors/doxymacs/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/editors/doxymacs/Makefile b/editors/doxymacs/Makefile
new file mode 100644
index 000000000000..086071848f20
--- /dev/null
+++ b/editors/doxymacs/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: w3 on Emacs21
+# Date created: 21 December 2003
+# Whom: Dryice Liu <dryice@liu.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= doxymacs
+PORTVERSION= 1.5.0
+CATEGORIES= editors elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dryice@liu.com.cn
+COMMENT= Doxymacs is Doxygen + {X}Emacs
+
+EMACS_PORT_NAME?= emacs21
+BUILD_DEPENDS= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/w3/w3.el:${PORTSDIR}/www/w3-4 \
+ xmllint:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/editors/doxymacs/distinfo b/editors/doxymacs/distinfo
new file mode 100644
index 000000000000..8194279541ac
--- /dev/null
+++ b/editors/doxymacs/distinfo
@@ -0,0 +1 @@
+MD5 (doxymacs-1.5.0.tar.gz) = 30d07e61acf1c94168e2313985eae1e2
diff --git a/editors/doxymacs/pkg-descr b/editors/doxymacs/pkg-descr
new file mode 100644
index 000000000000..30953a424a48
--- /dev/null
+++ b/editors/doxymacs/pkg-descr
@@ -0,0 +1,15 @@
+Doxymacs is Doxygen + {X}Emacs.
+
+The purpose of the doxymacs project is to create a LISP package that
+will make using Doxygen from within {X}Emacs easier.
+
+It has the following features:
+
+ * ability to look up documentation for symbols from {X}Emacs in
+ the browser of your choice.
+ * easily insert Doxygen style comments into source.
+ * optionally use an "external" (i.e. written in C) XML parser to
+ speed up building the completion list.
+ * fontify Doxygen keywords.
+
+WWW: http://doxymacs.sourceforge.net/
diff --git a/editors/doxymacs/pkg-plist b/editors/doxymacs/pkg-plist
new file mode 100644
index 000000000000..6bb9bcc6d25e
--- /dev/null
+++ b/editors/doxymacs/pkg-plist
@@ -0,0 +1,5 @@
+bin/doxymacs_parser
+%%EMACS_SITE_LISPDIR%%/doxymacs.el
+%%EMACS_SITE_LISPDIR%%/doxymacs.elc
+%%EMACS_SITE_LISPDIR%%/xml-parse.el
+%%EMACS_SITE_LISPDIR%%/xml-parse.elc