summaryrefslogtreecommitdiff
path: root/editors/doxymacs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/doxymacs/Makefile')
-rw-r--r--editors/doxymacs/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/editors/doxymacs/Makefile b/editors/doxymacs/Makefile
new file mode 100644
index 000000000000..086071848f20
--- /dev/null
+++ b/editors/doxymacs/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: w3 on Emacs21
+# Date created: 21 December 2003
+# Whom: Dryice Liu <dryice@liu.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= doxymacs
+PORTVERSION= 1.5.0
+CATEGORIES= editors elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dryice@liu.com.cn
+COMMENT= Doxymacs is Doxygen + {X}Emacs
+
+EMACS_PORT_NAME?= emacs21
+BUILD_DEPENDS= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/w3/w3.el:${PORTSDIR}/www/w3-4 \
+ xmllint:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>