summaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/libopensync/Makefile8
-rw-r--r--devel/libopensync022/Makefile8
2 files changed, 12 insertions, 4 deletions
diff --git a/devel/libopensync/Makefile b/devel/libopensync/Makefile
index 447ba3f165ae..8a00bf098c68 100644
--- a/devel/libopensync/Makefile
+++ b/devel/libopensync/Makefile
@@ -30,8 +30,12 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000 || ${ARCH} == "sparc64"
-BROKEN="Does not build"
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build on FreeBSD 4.x"
+.endif
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
.endif
pre-everything::
diff --git a/devel/libopensync022/Makefile b/devel/libopensync022/Makefile
index 447ba3f165ae..8a00bf098c68 100644
--- a/devel/libopensync022/Makefile
+++ b/devel/libopensync022/Makefile
@@ -30,8 +30,12 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000 || ${ARCH} == "sparc64"
-BROKEN="Does not build"
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build on FreeBSD 4.x"
+.endif
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
.endif
pre-everything::