summaryrefslogtreecommitdiff
path: root/devel/rlwrap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rlwrap/Makefile')
-rw-r--r--devel/rlwrap/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/devel/rlwrap/Makefile b/devel/rlwrap/Makefile
index d3a7649be6f0..bbd9ca2fce89 100644
--- a/devel/rlwrap/Makefile
+++ b/devel/rlwrap/Makefile
@@ -7,24 +7,27 @@
#
PORTNAME= rlwrap
-PORTVERSION= 0.10
+PORTVERSION= 0.12
CATEGORIES= devel
MASTER_SITES= http://utopia.knoware.nl/~hlub/uck/rlwrap/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500018
+BROKEN= "Requires readline 4.2 or newer"
+.endif
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
ALL_TARGET= # empty
-MANCOMPRESSED= no
MAN1= rlwrap.1
-post-patch:
- @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile.in
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>