summaryrefslogtreecommitdiff
path: root/devel/py-dbus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--devel/py-dbus/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/devel/py-dbus/Makefile b/devel/py-dbus/Makefile
index c62b179454cf..3dd972fbd2b9 100644
--- a/devel/py-dbus/Makefile
+++ b/devel/py-dbus/Makefile
@@ -3,10 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-#
+# $MCom: ports/devel/py-dbus/Makefile,v 1.8 2007/03/01 05:52:46 marcus Exp $
PORTNAME= dbus
-PORTVERSION= 0.71
+PORTVERSION= 0.80.2
+PORTREVISION= 1
CATEGORIES= devel gnome python
MASTER_SITES= http://dbus.freedesktop.org/releases/dbus-python/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,17 +16,23 @@ DISTNAME= ${PORTNAME}-python-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Python bindings for the D-BUS messaging system
-BUILD_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-RUN_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex \
- ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2
+USE_GNOME= gnomehack gnometarget
USE_PYTHON= yes
USE_GMAKE= yes
-USE_PYDISTUTILS=yes
+USE_AUTOTOOLS= libtool:15
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
post-install:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHONPREFIX_SITELIBDIR}/dbus
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHONPREFIX_SITELIBDIR}/dbus
+.if defined(NOPORTDOCS)
+ @${RM} -rf ${PREFIX}/share/doc/dbus-python
+.else
+ @${MV} ${PREFIX}/share/doc/dbus-python ${DOCSDIR} && \
+ ${MKDIR} ${EXAMPLESDIR} && \
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.py ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>