summaryrefslogtreecommitdiff
path: root/devel/portmk/Mk/bsd.port.post.mk
diff options
context:
space:
mode:
Diffstat (limited to 'devel/portmk/Mk/bsd.port.post.mk')
-rw-r--r--devel/portmk/Mk/bsd.port.post.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/portmk/Mk/bsd.port.post.mk b/devel/portmk/Mk/bsd.port.post.mk
index c36f5f38a68e..17b8a6db2bdd 100644
--- a/devel/portmk/Mk/bsd.port.post.mk
+++ b/devel/portmk/Mk/bsd.port.post.mk
@@ -1368,6 +1368,38 @@ makesum:
.endif
.endif
+.PHONY: master-sites-all
+.if !target(master-sites-all)
+master-sites-all:
+ @${_FETCHDISTFILES_ENV}; \
+ set -- -t ''; \
+ . '${DISTFILES_SH}'
+.endif
+
+.PHONY: master-sites
+.if !target(master-sites)
+master-sites:
+ @${_FETCHDISTFILES_ENV}; \
+ set -- -t 'DEFAULT'; \
+ . '${DISTFILES_SH}'
+.endif
+
+.PHONY: patch-sites-all
+.if !target(patch-sites-all)
+patch-sites-all:
+ @${_FETCHDISTFILES_ENV}; \
+ set -- -T ''; \
+ . '${DISTFILES_SH}'
+.endif
+
+.PHONY: patch-sites
+.if !target(patch-sites)
+patch-sites:
+ @${_FETCHDISTFILES_ENV}; \
+ set -- -T 'DEFAULT'; \
+ . '${DISTFILES_SH}'
+.endif
+
.PHONY: migratesum
.if !target(migratesum)
migratesum: