summaryrefslogtreecommitdiff
path: root/devel/p5-Exception-Class/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Exception-Class/Makefile')
-rw-r--r--devel/p5-Exception-Class/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/devel/p5-Exception-Class/Makefile b/devel/p5-Exception-Class/Makefile
index 819528419039..d421fab627f6 100644
--- a/devel/p5-Exception-Class/Makefile
+++ b/devel/p5-Exception-Class/Makefile
@@ -16,19 +16,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@FreeBSD.org
COMMENT= A module that allows you to declare real exception classes in Perl
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Devel/StackTrace.pm:${PORTSDIR}/devel/p5-Devel-StackTrace \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable
+BUILD_DEPENDS= ${SITE_PERL}/Devel/StackTrace.pm:${PORTSDIR}/devel/p5-Devel-StackTrace \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Exception::Class.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
.endif
.include <bsd.port.post.mk>