summaryrefslogtreecommitdiff
path: root/devel/motor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/motor/Makefile')
-rw-r--r--devel/motor/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/motor/Makefile b/devel/motor/Makefile
index 57426b92e32c..2029335d73db 100644
--- a/devel/motor/Makefile
+++ b/devel/motor/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= motor
-PORTVERSION= 3.2.3
+PORTVERSION= 3.2.4
CATEGORIES= devel
MASTER_SITES= http://konst.org.ua/download/
@@ -18,6 +18,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
+USE_REINPLACE= yes
MAN1= motor.1
@@ -27,6 +28,12 @@ MAN1= motor.1
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/_G_config.h/d' \
+ ${WRKSRC}/kkstrtext/conf.h \
+ ${WRKSRC}/kksystr/include/conf.h \
+ ${WRKSRC}/kkconsui/include/conf.h
+
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}