summaryrefslogtreecommitdiff
path: root/devel/gir-repository/bsd.gir.mk
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gir-repository/bsd.gir.mk')
-rw-r--r--devel/gir-repository/bsd.gir.mk64
1 files changed, 4 insertions, 60 deletions
diff --git a/devel/gir-repository/bsd.gir.mk b/devel/gir-repository/bsd.gir.mk
index 62fea33aad2d..cb9b4f1d1b9f 100644
--- a/devel/gir-repository/bsd.gir.mk
+++ b/devel/gir-repository/bsd.gir.mk
@@ -1,6 +1,6 @@
PORTNAME= gir-repository
PORTVERSION= 0.6.5
-PORTREVISION?= 4
+PORTREVISION?= 5
MAINTAINER= gnome@FreeBSD.org
@@ -9,31 +9,12 @@ GIRDIR= ${LOCALBASE}/share/gir-1.0
poppler_CATEGORY= graphics
poppler_GIR= Poppler-0.8
-libsoup_CATEGORY= devel
-libsoup_GIR= Soup-2.4
-libsoup_GIR_TMPL= soup
-
-dbus_CATEGORY= devel
-dbus_GIR= DBus-1.0
-
-gconf2_CATEGORY= devel
-gconf2_GIR= GConf-2.0
-
babl_CATEGORY= x11
babl_GIR= Babl-0.1
-nautilus_CATEGORY= x11-fm
-nautilus_GIR= Nautilus-1.0
-
-gnomekeyring_CATEGORY= security
-gnomekeyring_GIR= GnomeKeyring-2.0
-
libnotify_CATEGORY= devel
libnotify_GIR= Notify-0.4
-gtksourceview2_CATEGORY= x11-toolkits
-gtksourceview2_GIR= GtkSource-2.2
-
vte_CATEGORY= x11-toolkits
vte_GIR= Vte-1.0
@@ -48,7 +29,7 @@ DIST_SUBDIR= gnome2
COMMENT?= Introspection information for ${GIR_NAME}
BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-RUN_DEPENDS= ${GIRDIR}/Everything-1.0.gir:${PORTSDIR}/devel/gobject-introspection
+RUN_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -68,44 +49,20 @@ PLIST= ${NONEXISTENT}
_USE_GIR_ALL= dbus atk pango pangoxft poppler gtk gconf soup babl nautilusextension \
gnomekeyring webkit notify gnio clutter clutter_gtk clutter_cairo \
gstreamer gstbufferlist_h gstreamer_plugins_base gtksourceview vte \
- goocanvas gssdp gupnp unique gmenu wnck
+ goocanvas gssdp gupnp avahi unique gmenu wnck
.if ${GIR_NAME} == "poppler"
-LIB_DEPENDS+= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS+= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
USE_GNOME+= gtk20
GIR_FILES= Poppler-0.8
CLEAR_DEPS+= Gdk-2.0
.endif
-.if ${GIR_NAME} == "libsoup"
-LIB_DEPENDS+= soup-2.4.1:${PORTSDIR}/devel/libsoup
-GIR_FILES= Soup-2.4
-DEP_NAMES= soup
-.endif
-
-.if ${GIR_NAME} == "gconf2"
-USE_GNOME+= gconf2
-GIR_FILES= GConf-2.0
-DEP_NAMES= gconf
-.endif
-
.if ${GIR_NAME} == "babl"
LIB_DEPENDS+= babl-0.1.0:${PORTSDIR}/x11/babl
GIR_FILES= Babl-0.1
.endif
-.if ${GIR_NAME} == "nautilus"
-USE_GNOME+= nautilus2
-GIR_FILES= Nautilus-1.0
-DEP_NAMES= nautilusextension
-CLEAR_DEPS+= Gtk-2.0
-.endif
-
-.if ${GIR_NAME} == "gnomekeyring"
-LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
-GIR_FILES= GnomeKeyring-2.0
-.endif
-
.if ${GIR_NAME} == "libnotify"
LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
USE_GNOME+= gtk20
@@ -114,19 +71,6 @@ DEP_NAMES= notify
CLEAR_DEPS+= Gtk-2.0
.endif
-.if ${GIR_NAME} == "dbus"
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-GIR_FILES= DBus-1.0
-LIB_FILES= DBus
-.endif
-
-.if ${GIR_NAME} == "gtksourceview2"
-USE_GNOME+= gtksourceview2
-GIR_FILES= GtkSource-2.2
-DEP_NAMES= gtksourceview
-CLEAR_DEPS+= Gtk-2.0
-.endif
-
.if ${GIR_NAME} == "vte"
USE_GNOME+= vte
GIR_FILES= Vte-1.0