summaryrefslogtreecommitdiff
path: root/devel/esdl/files/patch-c__src_Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/esdl/files/patch-c__src_Makefile')
-rw-r--r--devel/esdl/files/patch-c__src_Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/esdl/files/patch-c__src_Makefile b/devel/esdl/files/patch-c__src_Makefile
new file mode 100644
index 000000000000..b8bd6fef9b74
--- /dev/null
+++ b/devel/esdl/files/patch-c__src_Makefile
@@ -0,0 +1,27 @@
+
+$FreeBSD$
+
+--- c_src/Makefile.orig Mon Dec 9 23:11:08 2002
++++ c_src/Makefile Mon Dec 9 23:11:10 2002
+@@ -5,7 +5,7 @@
+ # $Id: Makefile,v 1.3 2002/09/07 06:02:36 bjorng Exp $
+ #
+
+-OGLDIR = /usr
++OGLDIR = /usr/X11R6
+
+ # Uncomment these if your opengl header is located in another directory than
+ # the usual $(OGLDIR)/include/GL/gl.h
+@@ -15,10 +15,10 @@
+ GL_LIBS = -L$(OGLDIR)/lib -lGL -lGLU
+ GL_INCS = -I$(OGLDIR)/include/$(GL_INCLUDE_DIR)
+
+-SDL_LIBS = $(shell sdl-config --libs)
++SDL_LIBS = $(shell sdl11-config --libs)
+ LIBS = $(GL_LIBS) $(SDL_LIBS) -lm
+
+-SDLINCS = $(shell sdl-config --cflags)
++SDLINCS = $(shell sdl11-config --cflags)
+
+ CFLAGS = -g -O2 -funroll-loops -Wall -ffast-math -fpic -fomit-frame-pointer \
+ $(USE_GL_INCLUDE_DIR) -DSHM -DPTHREADS $(GL_INCS) $(SDLINCS)