summaryrefslogtreecommitdiff
path: root/deskutils/virt-manager/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/virt-manager/Makefile')
-rw-r--r--deskutils/virt-manager/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/deskutils/virt-manager/Makefile b/deskutils/virt-manager/Makefile
index 86394e7d6068..7d7d5f00b069 100644
--- a/deskutils/virt-manager/Makefile
+++ b/deskutils/virt-manager/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= virt-manager
-PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTVERSION= 0.9.3
CATEGORIES= deskutils net-mgmt
MASTER_SITES= http://virt-manager.et.redhat.com/download/sources/${PORTNAME}/
@@ -19,11 +18,21 @@ LICENSE= LGPL3
LIB_DEPENDS= virt.9:${PORTSDIR}/devel/libvirt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.2:${PORTSDIR}/devel/py-dbus \
${PYTHON_PKGNAMEPREFIX}libxml2>=2.7.8:${PORTSDIR}/textproc/py-libxml2 \
- ${PYTHON_PKGNAMEPREFIX}virtinst>=0.600.0:${PORTSDIR}/net-mgmt/virtinst \
+ ${PYTHON_PKGNAMEPREFIX}virtinst>=0.600.2:${PORTSDIR}/net-mgmt/virtinst \
${PYTHON_PKGNAMEPREFIX}vte>=0.26.2:${PORTSDIR}/x11-toolkits/py-vte \
gtk-vnc>=0.3.10:${PORTSDIR}/net/gtk-vnc \
librsvg2>=2.32.1:${PORTSDIR}/graphics/librsvg2
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
USE_GNOME= pygnome2
INSTALLS_ICONS= yes
GCONF_SCHEMAS= virt-manager.schemas
@@ -34,4 +43,8 @@ USE_PYTHON= yes
MAN1= virt-manager.1
+post-patch-script:
+ @${REINPLACE_CMD} -e 's|itlocaledir = $$(prefix)/$$(DATADIRNAME)/locale|itlocaledir = $$(prefix)/share/locale|' \
+ ${WRKSRC}/po/Makefile.in.in
+
.include <bsd.port.mk>