summaryrefslogtreecommitdiff
path: root/deskutils/nautilus-sendto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/nautilus-sendto/Makefile')
-rw-r--r--deskutils/nautilus-sendto/Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/deskutils/nautilus-sendto/Makefile b/deskutils/nautilus-sendto/Makefile
index 00cb7eb98dc5..08a6d2682223 100644
--- a/deskutils/nautilus-sendto/Makefile
+++ b/deskutils/nautilus-sendto/Makefile
@@ -3,11 +3,10 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/deskutils/nautilus-sendto/Makefile,v 1.25 2010/04/10 23:24:02 kwm Exp $
+# $MCom: ports/deskutils/nautilus-sendto/Makefile,v 1.30 2010/09/30 06:21:18 kwm Exp $
PORTNAME= nautilus-sendto
-PORTVERSION= 2.28.4
-PORTREVISION= 2
+PORTVERSION= 2.32.0
CATEGORIES= deskutils
MASTER_SITES= GNOME
@@ -15,24 +14,23 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Integration between nautilus, evolution, and pidgin
MAN1= nautilus-sendto.1
-GCONF_SCHEMAS= nst.schemas
+GLIB_SCHEMAS= org.gnome.Nautilus.Sendto.gschema.xml
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= intlhack gnomeprefix gnometarget nautilus2 gnomehack \
evolutiondataserver
+GNOME_DESKTOP_VERSION=2
USE_GETTEXT= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-plugins="${SENDTO_PLUGINS}"
-OPTIONS= PIDGIN "Build pidgin sendto plugin" off
+OPTIONS= PIDGIN "Build pidgin sendto plugin" off \
+ UPNP "Build upnp sendto plugin" off
# check configure script for allowed_plugins="..." for new plugins
-SENDTO_PLUGINS= bluetooth evolution gajim nautilus-burn removable-devices
-
-# Not these plugins:
-# empathy (moved to empathy port) upnp
+SENDTO_PLUGINS= evolution gajim nautilus-burn removable-devices
.include <bsd.port.pre.mk>
@@ -45,4 +43,12 @@ PLIST_SUB+= PIDGIN=""
PLIST_SUB+= PIDGIN="@comment "
.endif
+.if defined(WITH_UPNP)
+SENDTO_PLUGINS:=${SENDTO_PLUGINS} upnp
+LIB_DEPENDS+= gupnp-1.0:${PORTSDIR}/net/gupnp
+PLIST_SUB+= UPNP=""
+.else
+PLIST_SUB+= UPNP="@comment "
+.endif
+
.include <bsd.port.post.mk>