summaryrefslogtreecommitdiff
path: root/deskutils/gcal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gcal/Makefile')
-rw-r--r--deskutils/gcal/Makefile45
1 files changed, 29 insertions, 16 deletions
diff --git a/deskutils/gcal/Makefile b/deskutils/gcal/Makefile
index 4f992206d69e..0d3ead6929b5 100644
--- a/deskutils/gcal/Makefile
+++ b/deskutils/gcal/Makefile
@@ -6,32 +6,45 @@
#
PORTNAME= gcal
-PORTVERSION= 3.01
-PORTREVISION= 7
+PORTVERSION= 3.6
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@FreeBSD.org
COMMENT= The GNU Gregorian calendar program
-# Global variables
-#
-
USE_GETTEXT= yes
-# required to rebuild info files if needed.
-USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
INFO= gcal
-MAN1= gcal.1 gcal2txt.1 tcal.1 txt2gcal.1
+#MAN1= gcal.1 gcal2txt.1 tcal.1 txt2gcal.1
-# Post-extract
-#
-
-# it's not so simple to get rid of splitted *.info-* files
-# w/ hacking doc/Makefile.in. so, do nothing and left them.
-# post-extract:
-# @${RM} -f ${WRKSRC}/doc/*/${PORTNAME}.info*
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+GCAL_SCRIPTS= daily/daily ddiff/ddiff ddiff/ddiffdrv dst/dst gcalltx/gcalltx \
+ gcalltx/gcalltxp moon/moon mrms/mrms srss/srss wloc/wlocdrv
+
+post-patch:
+.for p in ${GCAL_SCRIPTS}
+ @${REINPLACE_CMD} -e '/^ThisGcal=/s:=.*:=${PREFIX}/bin/gcal:' \
+ -e '/^packagedatamiscdir=/s:=.*:=${DATADIR}/misc/${p:H}:' \
+ ${WRKSRC}/misc/${p}.in
+.endfor
+
+post-install:
+ @${TAR} -cf - -C ${WRKSRC} --exclude '*.in' --exclude '*.in.bak' \
+ --exclude '*.alias' misc | ${TAR} -xpf - -C ${DATADIR}
+.for p in ${GCAL_SCRIPTS}
+ @${CHMOD} +x ${DATADIR}/misc/${p}
+ @${LN} -s ${DATADIR}/misc/${p} ${PREFIX}/bin/gcal-${p:T}
+.endfor
.include <bsd.port.mk>