summaryrefslogtreecommitdiff
path: root/databases/p5-MyObject/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-MyObject/Makefile')
-rw-r--r--databases/p5-MyObject/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/databases/p5-MyObject/Makefile b/databases/p5-MyObject/Makefile
new file mode 100644
index 000000000000..18675a97c1fa
--- /dev/null
+++ b/databases/p5-MyObject/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-MyObject
+# Version required: 1.0
+# Date created: 14 November 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD: /tmp/pcvs/ports/databases/p5-MyObject/Attic/Makefile,v 1.1.1.1 1999-11-27 05:38:29 steve Exp $
+#
+
+DISTNAME= MyObject.pm
+PKGNAME= p5-MyObject-1.0
+CATEGORIES= databases perl5
+MASTER_SITES= http://www.frontierworld.com/perl/
+EXTRACT_SUFX=
+
+MAINTAINER= jedgar@fxp.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql
+
+USE_PERL5= yes
+POD2MAN= /usr/bin/pod2man
+NO_BUILD= yes
+
+MAN3= MyObject.3
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+ @(cd ${WRKSRC}; ${POD2MAN} MyObject.pm > MyObject.3)
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/MyObject.pm ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}
+ ${INSTALL_MAN} ${WRKSRC}/MyObject.3 ${PREFIX}/man/man3
+
+.include <bsd.port.mk>