summaryrefslogtreecommitdiff
path: root/databases/mysql-editor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--databases/mysql-editor/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/databases/mysql-editor/Makefile b/databases/mysql-editor/Makefile
index a5d70121aeb3..02a4513237fc 100644
--- a/databases/mysql-editor/Makefile
+++ b/databases/mysql-editor/Makefile
@@ -15,7 +15,9 @@ DISTNAME= ${PORTNAME}
MAINTAINER= mi@aldan.algebra.com
COMMENT= CGI scripts in Perl to edit your MySQL tables
-RUN_DEPENDS= ${CGI_BIN}:${PORTSDIR}/${APACHE_PORT}
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${CGI_BIN}:${PORTSDIR}/${APACHE_PORT} \
+ ${BUILD_DEPENDS}
NO_BUILD= True
APACHE_COMPAT= True
@@ -32,14 +34,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/readme.html ${PREFIX}/share/doc/mysql-editor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>