summaryrefslogtreecommitdiff
path: root/databases/libgda4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--databases/libgda4/Makefile59
1 files changed, 33 insertions, 26 deletions
diff --git a/databases/libgda4/Makefile b/databases/libgda4/Makefile
index 23a78523a2fd..30868bae3fa3 100644
--- a/databases/libgda4/Makefile
+++ b/databases/libgda4/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/databases/libgda4/Makefile,v 1.4 2010/06/23 21:29:32 kwm Exp $
+# $MCom: ports/databases/libgda4/Makefile,v 1.14 2010/11/14 20:57:58 kwm Exp $
#
PORTNAME= libgda4
-PORTVERSION?= 4.0.9
+PORTVERSION?= 4.2.1
PORTREVISION?= 0
CATEGORIES= databases gnome
MASTER_SITES= GNOME
@@ -25,6 +25,7 @@ LIBGDA4_SLAVE?= no
BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+ gcrypt.17:${PORTSDIR}/security/libgcrypt \
soup-2.4.1:${PORTSDIR}/devel/libsoup \
json-glib-1.0.0:${PORTSDIR}/devel/json-glib
RUN_DEPENDS= ${LOCALBASE}/lib/girepository-1.0/GObject-2.0.typelib:${PORTSDIR}/devel/gobject-introspection
@@ -36,11 +37,19 @@ USE_GNOME= gnomeprefix gnomehack glib20 libxslt intlhack referencehack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE=yes
-CONFIGURE_ARGS= --without-sybase \
- --enable-introspection
+CONFIGURE_ARGS= --without-oracle \
+ --enable-introspection=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
+.if ${LIBGDA4_SLAVE}=="no"
+OPTIONS= UI "Build UI tools" on
+.endif
+
+.if defined(WITH_UI)
+INSTALLS_ICONS= yes
+.endif
+
.include <bsd.port.pre.mk>
#VERSION= ${PORTVERSION:R}
@@ -48,6 +57,16 @@ VERSION= 4.0
PLIST_SUB= VERSION=${VERSION}
.if ${LIBGDA4_SLAVE}=="no"
+.if defined(WITH_UI)
+CONFIGURE_ARGS+=--with-ui
+BUILD_DEPENDS+= xml2po:${PORTSDIR}/textproc/gnome-doc-utils
+USE_GNOME+= gtk20
+PLIST_SUB+= UI=""
+.else
+CONFIGURE_ARGS+=--without-ui
+PLIST_SUB+= UI="@comment "
+.endif
+
MAN1= gda-sql.1 gda-sql-4.0.1
.else
USE_GNOME+= libgda4
@@ -74,13 +93,6 @@ CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
CONFIGURE_ARGS+= --without-postgres
.endif
-.if ${LIBGDA4_SLAVE}=="ldap"
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --without-ldap
-.endif
-
.if ${LIBGDA4_SLAVE}=="firebird"
LIB_DEPENDS+= gds.2:${PORTSDIR}/databases/firebird2-client
CONFIGURE_ARGS+= --with-firebird=${LOCALBASE}
@@ -88,13 +100,6 @@ CONFIGURE_ARGS+= --with-firebird=${LOCALBASE}
CONFIGURE_ARGS+= --without-firebird
.endif
-.if ${LIBGDA4_SLAVE}=="freetds"
-LIB_DEPENDS+= tds.5:${PORTSDIR}/databases/freetds
-CONFIGURE_ARGS+= --with-tds=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --without-tds
-.endif
-
# MDB (MS Access)
.if ${LIBGDA4_SLAVE}=="mdb"
LIB_DEPENDS+= mdbsql.0:${PORTSDIR}/databases/mdbtools
@@ -103,13 +108,6 @@ CONFIGURE_ARGS+= --with-mdb=${LOCALBASE}
CONFIGURE_ARGS+= --without-mdb
.endif
-.if ${LIBGDA4_SLAVE}=="odbc"
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
-CONFIGURE_ARGS+= --with-odbc=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --without-odbc
-.endif
-
.if ${LIBGDA4_SLAVE}=="jdbc"
USE_JAVA= yes
JAVA_VENDOR= bsdjava openjdk
@@ -135,12 +133,21 @@ post-patch:
${WRKSRC}/providers/bdb/gda-bdb-test.c
.if ${LIBGDA4_SLAVE}!="no"
#. for d in msql firebird odbc freetds mdb ldap mysql sqlite postgres
-. for d in bdb jdbc mdb mysql postgres
+. for d in bdb jdbc mdb mysql postgres reuseable/postgres reuseable/mysql
@${REINPLACE_CMD} -e 's|$$(top_builddir)/libgda/libgda-4.0.la|${LOCALBASE}/lib/libgda-4.0.la|g' \
${WRKSRC}/providers/${d}/Makefile.in
. endfor
.endif
+pre-build:
+.if ${LIBGDA4_SLAVE}=="postgresql"
+ cd ${WRKSRC}/providers/reuseable/postgres && ${GMAKE} libgda-postgres.la
+.endif
+
+.if ${LIBGDA4_SLAVE}=="mysql"
+ cd ${WRKSRC}/providers/reuseable/mysql && ${GMAKE} libgda-mysql.la
+.endif
+
.if ${LIBGDA4_SLAVE}=="no"
post-install:
${INSTALL_DATA} ${WRKSRC}/data/config \