summaryrefslogtreecommitdiff
path: root/databases/libgda2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/libgda2/Makefile')
-rw-r--r--databases/libgda2/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/databases/libgda2/Makefile b/databases/libgda2/Makefile
index 5baad1b6a879..3387be688dd8 100644
--- a/databases/libgda2/Makefile
+++ b/databases/libgda2/Makefile
@@ -45,7 +45,8 @@ PLIST_SUB= MYSQL="@comment "
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
PLIST_SUB+= POSTGRES=""
.else