summaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
Diffstat (limited to 'chinese')
-rw-r--r--chinese/mldonkey-core/Makefile10
-rw-r--r--chinese/mldonkey-core/files/wrapper-prefix6
2 files changed, 16 insertions, 0 deletions
diff --git a/chinese/mldonkey-core/Makefile b/chinese/mldonkey-core/Makefile
index e60bd3fa4bf5..c4ab3152e175 100644
--- a/chinese/mldonkey-core/Makefile
+++ b/chinese/mldonkey-core/Makefile
@@ -17,6 +17,16 @@ WITHOUT_GUI= yes
MASTERDIR= ${.CURDIR}/../../net/mldonkey
EXTRA_PATCHES= ${.CURDIR}/files/patch-driverControlers.ml
+WRAPPERPREFIX= ${.CURDIR}/files/wrapper-prefix
+WRAPPER= ${WRKDIR}/wrapper.sh
+
+# build our own wrapper script
+post-patch-script:
+ @${MV} -f ${WRAPPER} ${WRAPPER}.orig
+ @${CAT} ${WRAPPERPREFIX} ${WRAPPER}.orig > ${WRAPPER}
+
.include "${MASTERDIR}/Makefile"
+# I know this will lead portlint to fail,
+# but we have to do so.
PKGNAMEPREFIX:= ${PKGNAMEPREFIX}tw-
diff --git a/chinese/mldonkey-core/files/wrapper-prefix b/chinese/mldonkey-core/files/wrapper-prefix
new file mode 100644
index 000000000000..3c32d53ad7ea
--- /dev/null
+++ b/chinese/mldonkey-core/files/wrapper-prefix
@@ -0,0 +1,6 @@
+#!/bin/sh
+# Force printing non-quote(escaped) instead of \xxx
+
+LC_CTYPE=en_US.ISO8859-1
+export LC_CTYPE
+