summaryrefslogtreecommitdiff
path: root/audio/snack
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--audio/snack/Makefile3
-rw-r--r--audio/snack/files/patch-configure11
-rw-r--r--audio/snack/files/patch-generic-jkFormatMP3.c18
-rw-r--r--audio/snack/files/patch-generic_jkFormatMP3.c18
-rw-r--r--audio/snack/files/patch-unix_configure11
5 files changed, 31 insertions, 30 deletions
diff --git a/audio/snack/Makefile b/audio/snack/Makefile
index 29c9593f0dc2..5349ba3b969b 100644
--- a/audio/snack/Makefile
+++ b/audio/snack/Makefile
@@ -18,7 +18,8 @@ USES= tk:tea
USE_LDCONFIG= ${PREFIX}/lib/snack${PORTVERSION:R}
MAKE_ENV= prefix=${PREFIX} exec_prefix=${PREFIX}
-WRKSRC= ${WRKDIR}/${DISTNAME}/unix
+WRKSRC_SUBDIR= unix
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
PLIST_SUB= SNACK_VER=${PORTVERSION:R}
PORTDOCS= *
diff --git a/audio/snack/files/patch-configure b/audio/snack/files/patch-configure
deleted file mode 100644
index 153d3c0c30a6..000000000000
--- a/audio/snack/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2005-12-14 11:29:39 UTC
-+++ configure
-@@ -1487,7 +1487,7 @@ if test "$TCL_SHARED_BUILD" = 0; then
- echo "$as_me: error: Tcl and Tk must be configured with the --enable-shared flag" >&2;}
- { (exit 1); exit 1; }; }
- fi
--CFLAGS=$TCL_SHLIB_CFLAGS
-+CFLAGS="$CFLAGS $TCL_SHLIB_CFLAGS"
- LD_SEARCH_FLAGS=$TCL_LD_SEARCH_FLAGS
- SHLIB_LD=$TCL_SHLIB_LD
- SHLIB_SUFFIX=$TCL_SHLIB_SUFFIX
diff --git a/audio/snack/files/patch-generic-jkFormatMP3.c b/audio/snack/files/patch-generic-jkFormatMP3.c
deleted file mode 100644
index 7f509dac31c7..000000000000
--- a/audio/snack/files/patch-generic-jkFormatMP3.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- ../generic/jkFormatMP3.c.orig 2005-12-14 11:29:38 UTC
-+++ ../generic/jkFormatMP3.c
-@@ -31,7 +31,6 @@ must retain this copyright notice.
- #include <string.h>
- #define FRAS2(is,a) ((is) > 0 ? t_43[(is)]*(a):-t_43[-(is)]*(a))
- #define MAXFRAMESIZE 2106 /* frame size starting at header */
--#define roundf(x) (floor((x)+(float )0.5f))
- static char *gblOutputbuf;
- static char *gblReadbuf;
- static int gblBufind = 0;
-@@ -1311,6 +1310,7 @@ huffman_decode(int tbl,int *x,int *y)
-
- #include <math.h>
-
-+#define roundf(x) (floor((x)+(float )0.5f))
- #define PI12 0.261799387f
- #define PI36 0.087266462f
- #define COSPI3 0.500000000f
diff --git a/audio/snack/files/patch-generic_jkFormatMP3.c b/audio/snack/files/patch-generic_jkFormatMP3.c
new file mode 100644
index 000000000000..48d7c79966ff
--- /dev/null
+++ b/audio/snack/files/patch-generic_jkFormatMP3.c
@@ -0,0 +1,18 @@
+--- generic/jkFormatMP3.c.orig 2005-12-14 11:29:38 UTC
++++ generic/jkFormatMP3.c
+@@ -31,7 +31,6 @@ must retain this copyright notice.
+ #include <string.h>
+ #define FRAS2(is,a) ((is) > 0 ? t_43[(is)]*(a):-t_43[-(is)]*(a))
+ #define MAXFRAMESIZE 2106 /* frame size starting at header */
+-#define roundf(x) (floor((x)+(float )0.5f))
+ static char *gblOutputbuf;
+ static char *gblReadbuf;
+ static int gblBufind = 0;
+@@ -1311,6 +1310,7 @@ huffman_decode(int tbl,int *x,int *y)
+
+ #include <math.h>
+
++#define roundf(x) (floor((x)+(float )0.5f))
+ #define PI12 0.261799387f
+ #define PI36 0.087266462f
+ #define COSPI3 0.500000000f
diff --git a/audio/snack/files/patch-unix_configure b/audio/snack/files/patch-unix_configure
new file mode 100644
index 000000000000..0cb4ac67d334
--- /dev/null
+++ b/audio/snack/files/patch-unix_configure
@@ -0,0 +1,11 @@
+--- unix/configure.orig 2005-12-14 11:29:39 UTC
++++ unix/configure
+@@ -1487,7 +1487,7 @@ if test "$TCL_SHARED_BUILD" = 0; then
+ echo "$as_me: error: Tcl and Tk must be configured with the --enable-shared flag" >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+-CFLAGS=$TCL_SHLIB_CFLAGS
++CFLAGS="$CFLAGS $TCL_SHLIB_CFLAGS"
+ LD_SEARCH_FLAGS=$TCL_LD_SEARCH_FLAGS
+ SHLIB_LD=$TCL_SHLIB_LD
+ SHLIB_SUFFIX=$TCL_SHLIB_SUFFIX