summaryrefslogtreecommitdiff
path: root/astro/ptiger/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/ptiger/Makefile')
-rw-r--r--astro/ptiger/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/astro/ptiger/Makefile b/astro/ptiger/Makefile
new file mode 100644
index 000000000000..de8aa6dd4b70
--- /dev/null
+++ b/astro/ptiger/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ptiger
+# Date created: 26 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ptiger
+PORTVERSION= 2.2
+CATEGORIES= astro tk84
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= tkgeomap
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Displays U.S. Census Burea populated places on a map
+
+LIB_DEPENDS= tkgeomap2.9.0:${PORTSDIR}/astro/tkgeomap
+
+USE_XLIB= yes
+USE_TK= yes
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's,\[pwd\],${DATADIR}/src,;s,(lines/|places/|src/),${DATADIR}/\1,g;s,wish,${WISH},' ${WRKSRC}/src/PTiger.tcl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/src/PTiger.tcl ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL} -d ${DATADIR}
+ @${CP} -Rf ${WRKSRC}/lines ${WRKSRC}/places ${WRKSRC}/src ${DATADIR}/
+
+.include <bsd.port.mk>