summaryrefslogtreecommitdiff
path: root/astro/planets/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/planets/Makefile')
-rw-r--r--astro/planets/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/astro/planets/Makefile b/astro/planets/Makefile
new file mode 100644
index 000000000000..0ba3223fefbb
--- /dev/null
+++ b/astro/planets/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: planets
+# Date created: Mar 15, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= planets
+PORTVERSION= 0.1.5
+CATEGORIES= astro
+MASTER_SITES= http://planets.homedns.org/dist/${PORTVERSION}/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ocaml:${PORTSDIR}/lang/ocaml
+
+USE_GMAKE= yes
+ALL_TARGET= ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in KEYBINDINGS.txt getting_started.html
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>