summaryrefslogtreecommitdiff
path: root/Mk/bsd.sdl.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.sdl.mk')
-rw-r--r--Mk/bsd.sdl.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/Mk/bsd.sdl.mk b/Mk/bsd.sdl.mk
index ae1dc5bf5802..52e0adcbe313 100644
--- a/Mk/bsd.sdl.mk
+++ b/Mk/bsd.sdl.mk
@@ -56,7 +56,7 @@ _VERSION_gui= 0
_SUBDIR_gui= x11-toolkits
_REQUIRES_gui= sdl image ttf
-_VERSION_image= 10
+_VERSION_image= 1
_SUBDIR_image= graphics
_REQUIRES_image=sdl
@@ -74,17 +74,16 @@ _VERSION_net= 0
_SUBDIR_net= net
_REQUIRES_net= sdl
-_VERSION_sdl= 7
+_VERSION_sdl= 11
_SUBDIR_sdl= devel
-_LIB_sdl= SDL-1.1
+_LIB_sdl= SDL
_PORTDIR_sdl= sdl12
_VERSION_sound= 1
_SUBDIR_sound= audio
-_LIB_sound= SDL_sound-1.0
_REQUIRES_sound=sdl
-_VERSION_ttf= 3
+_VERSION_ttf= 6
_SUBDIR_ttf= graphics
_REQUIRES_ttf= sdl
@@ -171,7 +170,7 @@ LIB_DEPENDS+= ${_LIB_${component}}.${_VERSION_${component}}:${PORTSDIR}/${_SUBDI
# "Normal" dependencies and variables
#
BUILD_DEPENDS+= ${SDL_CONFIG}:${PORTSDIR}/${_SUBDIR_sdl}/${_PORTDIR_sdl}
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
MAKE_ENV+= SDL_CONFIG=${SDL_CONFIG}