summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/p5-Class-DBI-DDL/Makefile9
-rw-r--r--devel/p5-Class-Roles/Makefile9
-rw-r--r--devel/p5-Data-Taxonomy-Tags/Makefile9
-rw-r--r--devel/p5-Log-Dispatch-Email-EmailSend/Makefile9
-rw-r--r--devel/p5-Tree-Node/Makefile9
-rw-r--r--editors/p5-Padre/Makefile4
-rw-r--r--games/p5-Algorithm-Pair-Swiss/Makefile9
-rw-r--r--games/p5-Games-AlphaBeta/Makefile9
-rw-r--r--graphics/p5-CAD-Drawing-Template/Makefile9
-rw-r--r--graphics/p5-SVG-Graph/Makefile3
-rw-r--r--mail/p5-Mail-SPF/Makefile3
-rw-r--r--math/p5-AI-Perceptron/Makefile9
-rw-r--r--math/p5-CAD-Calc/Makefile9
-rw-r--r--math/p5-Math-Geometry-Planar-Offset/Makefile9
-rw-r--r--math/p5-Math-Round-Var/Makefile9
-rw-r--r--misc/p5-LEGO-RCX/Makefile1
-rw-r--r--net/p5-Net-Address-IPv4-Local/Makefile9
-rw-r--r--security/p5-Tree-Authz/Makefile9
-rw-r--r--textproc/p5-AI-Categorizer/Makefile9
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel-Styler/Makefile3
-rw-r--r--textproc/p5-Text-Decorator/Makefile9
-rw-r--r--textproc/p5-Text-Unaccent/Makefile10
-rw-r--r--textproc/p5-Unicode-Escape/Makefile9
-rw-r--r--textproc/p5-XML-XBEL/Makefile9
-rw-r--r--www/p5-CGI-Application-Dispatch-Server/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-AnyTemplate/Makefile9
-rw-r--r--www/p5-CGI-Application-Plugin-Authentication/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-Authorization/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-HTMLPrototype/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-LinkIntegrity/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-LogDispatch/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-MessageStack/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-Redirect/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-Session/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-Stream/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-TT/Makefile3
-rw-r--r--www/p5-CGI-Application-Plugin-ViewCode/Makefile3
-rw-r--r--www/p5-Catalyst-Controller-BindLex/Makefile3
-rw-r--r--www/p5-Template-Iterator-AlzaboWrapperCursor/Makefile9
-rw-r--r--x11-toolkits/p5-Gnome2-Canvas/Makefile4
-rw-r--r--x11-toolkits/p5-Gnome2-VFS/Makefile4
-rw-r--r--x11-toolkits/p5-Gtk2-Html2/Makefile4
42 files changed, 103 insertions, 152 deletions
diff --git a/databases/p5-Class-DBI-DDL/Makefile b/databases/p5-Class-DBI-DDL/Makefile
index b5258632c50c..d96ec7d84057 100644
--- a/databases/p5-Class-DBI-DDL/Makefile
+++ b/databases/p5-Class-DBI-DDL/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Class-DBI-DDL
-# Date created: 18 january 2005
-# Whom: Daniel Wijnands <daniel@itxl.nl>
-#
+# Created by: Daniel Wijnands <daniel@itxl.nl>
# $FreeBSD$
-#
PORTNAME= Class-DBI-DDL
PORTVERSION= 1.02
@@ -17,7 +13,8 @@ COMMENT= DDL for Class-DBI
RUN_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Class::DBI::DDL.3 \
Class::DBI::DDL::Pg.3
diff --git a/devel/p5-Class-Roles/Makefile b/devel/p5-Class-Roles/Makefile
index b35e7faa3af6..931229b8cd75 100644
--- a/devel/p5-Class-Roles/Makefile
+++ b/devel/p5-Class-Roles/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Class-Roles
-# Date Created: 17 Feb, 2004
-# Whom: Alex Kapranoff <kappa@freebsd.org.ua>
-#
+# Created by: Alex Kapranoff <kappa@freebsd.org.ua>
# $FreeBSD$
-#
PORTNAME= Class-Roles
PORTVERSION= 0.30
@@ -17,7 +13,8 @@ COMMENT= Provides a role-based system of OOP (emulates Perl6)
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Class::Roles.3
diff --git a/devel/p5-Data-Taxonomy-Tags/Makefile b/devel/p5-Data-Taxonomy-Tags/Makefile
index 07f3dba46083..1a4f6668e485 100644
--- a/devel/p5-Data-Taxonomy-Tags/Makefile
+++ b/devel/p5-Data-Taxonomy-Tags/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Data-Taxonomy-Tags
-# Date created: 26 June 2005
-# Whom: Aaron Dalton <aaron@daltons.ca>
-#
+# Created by: Aaron Dalton <aaron@daltons.ca>
# $FreeBSD$
-#
PORTNAME= Data-Taxonomy-Tags
PORTVERSION= 0.05
@@ -16,6 +12,7 @@ COMMENT= Represents a set of tags for any item
MAN3= Data::Taxonomy::Tags.3 Data::Taxonomy::Tags::Tag.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/devel/p5-Log-Dispatch-Email-EmailSend/Makefile b/devel/p5-Log-Dispatch-Email-EmailSend/Makefile
index 5068707922f1..67355bc44c3e 100644
--- a/devel/p5-Log-Dispatch-Email-EmailSend/Makefile
+++ b/devel/p5-Log-Dispatch-Email-EmailSend/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Log-Dispatch-Email-EmailSend
-# Date created: 2 August 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Log-Dispatch-Email-EmailSend
DISTVERSION= 0.03
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-Email-Send>=2.0:${PORTSDIR}/mail/p5-Email-Send \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= YES
+USES= perl5
+USE_PERL5= modbuild
MAN3= ${PORTNAME:S/-/::/g}.3
diff --git a/devel/p5-Tree-Node/Makefile b/devel/p5-Tree-Node/Makefile
index 3b63d8c21750..b31c243d4822 100644
--- a/devel/p5-Tree-Node/Makefile
+++ b/devel/p5-Tree-Node/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tree-Node
-# Date created: 01 July 2005
-# Whom: Aaron Dalton <aaron@daltons.ca>
-#
+# Created by: Aaron Dalton <aaron@daltons.ca>
# $FreeBSD$
-#
PORTNAME= Tree-Node
PORTVERSION= 0.08
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Memory-efficient tree nodes in Perl
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Tree::Node.3
diff --git a/editors/p5-Padre/Makefile b/editors/p5-Padre/Makefile
index b0607c6dd73e..71b21d6d7c79 100644
--- a/editors/p5-Padre/Makefile
+++ b/editors/p5-Padre/Makefile
@@ -70,8 +70,8 @@ USE_WX= 2.8+
WX_COMPS= wx contrib
WX_UNICODE= yes
USE_DISPLAY= yes
-PERL_CONFIGURE= yes
-USES= gettext
+USES= perl5 gettext
+USE_PERL5= configure
MAKE_JOBS_UNSAFE= yes
PLIST_SUB= WX_VERSION="${WX_VERSION}"
diff --git a/games/p5-Algorithm-Pair-Swiss/Makefile b/games/p5-Algorithm-Pair-Swiss/Makefile
index bd8401256653..bb56231de9c9 100644
--- a/games/p5-Algorithm-Pair-Swiss/Makefile
+++ b/games/p5-Algorithm-Pair-Swiss/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Algorithm-Pair-Swiss
-# Date created: 12 Jun 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Algorithm-Pair-Swiss
PORTVERSION= 0.14
@@ -18,6 +14,7 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
MAN3= Algorithm::Pair::Swiss.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/games/p5-Games-AlphaBeta/Makefile b/games/p5-Games-AlphaBeta/Makefile
index 46f54e80ec8e..920da704e490 100644
--- a/games/p5-Games-AlphaBeta/Makefile
+++ b/games/p5-Games-AlphaBeta/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Games-AlphaBeta
-# Date created: 27 July 2005
-# Whom: Aaron Dalton <aaron@daltons.ca>
-#
+# Created by: Aaron Dalton <aaron@daltons.ca>
# $FreeBSD$
-#
PORTNAME= Games-AlphaBeta
PORTVERSION= 0.4.7
@@ -15,7 +11,8 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Game-tree search with object oriented interface
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= othello-demo.1
MAN3= Games::AlphaBeta.3 Games::AlphaBeta::Position.3 \
diff --git a/graphics/p5-CAD-Drawing-Template/Makefile b/graphics/p5-CAD-Drawing-Template/Makefile
index cc0d7ef88cb4..1b2537269b41 100644
--- a/graphics/p5-CAD-Drawing-Template/Makefile
+++ b/graphics/p5-CAD-Drawing-Template/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: CAD-Drawing-Template
-# Date created: 22 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= CAD-Drawing-Template
PORTVERSION= 0.01
@@ -21,6 +17,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= CAD::Drawing::Template.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/graphics/p5-SVG-Graph/Makefile b/graphics/p5-SVG-Graph/Makefile
index 615d042907b6..e60c74bbee03 100644
--- a/graphics/p5-SVG-Graph/Makefile
+++ b/graphics/p5-SVG-Graph/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Math-Spline>=0:${PORTSDIR}/math/p5-Math-Spline \
p5-Tree-DAG_Node>=0:${PORTSDIR}/devel/p5-Tree-DAG_Node
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= SVG::Graph.3 \
SVG::Graph::Data.3 \
diff --git a/mail/p5-Mail-SPF/Makefile b/mail/p5-Mail-SPF/Makefile
index f79aa25f22e0..80a26d95d3d7 100644
--- a/mail/p5-Mail-SPF/Makefile
+++ b/mail/p5-Mail-SPF/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
CONFLICTS= p5-Mail-SPF-Query-[0-9]*
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
CONFIGURE_ARGS= --install_path sbin=${PREFIX}/sbin
MAN1= spfquery.pl.1
diff --git a/math/p5-AI-Perceptron/Makefile b/math/p5-AI-Perceptron/Makefile
index 936615701e11..0a917e5f23d0 100644
--- a/math/p5-AI-Perceptron/Makefile
+++ b/math/p5-AI-Perceptron/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: AI-Perceptron
-# Date created: 04 Nov 2000
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= AI-Perceptron
PORTVERSION= 1.0
@@ -17,7 +13,8 @@ COMMENT= Perl module for introducing to internal operations of neural networks
BUILD_DEPENDS= p5-accessors>=0:${PORTSDIR}/devel/p5-accessors
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= AI::Perceptron.3
diff --git a/math/p5-CAD-Calc/Makefile b/math/p5-CAD-Calc/Makefile
index 8f778981cfc4..f5aaac3695fd 100644
--- a/math/p5-CAD-Calc/Makefile
+++ b/math/p5-CAD-Calc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: CAD-Calc
-# Date created: 21 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= CAD-Calc
PORTVERSION= 0.27
@@ -22,6 +18,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= CAD::Calc.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/math/p5-Math-Geometry-Planar-Offset/Makefile b/math/p5-Math-Geometry-Planar-Offset/Makefile
index f64a55bf63cf..38b24d8c754d 100644
--- a/math/p5-Math-Geometry-Planar-Offset/Makefile
+++ b/math/p5-Math-Geometry-Planar-Offset/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Math-Geometry-Planar-Offset
-# Date created: 21 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Math-Geometry-Planar-Offset
PORTVERSION= 1.05
@@ -19,6 +15,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Geometry::Planar::Offset.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/math/p5-Math-Round-Var/Makefile b/math/p5-Math-Round-Var/Makefile
index db971d32e351..c936cffdbf3e 100644
--- a/math/p5-Math-Round-Var/Makefile
+++ b/math/p5-Math-Round-Var/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Math-Round-Var
-# Date created: 21 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Math-Round-Var
PORTVERSION= 1.0.0
@@ -17,6 +13,7 @@ COMMENT= Variations on rounding
MAN3= Math::Round::Var.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/misc/p5-LEGO-RCX/Makefile b/misc/p5-LEGO-RCX/Makefile
index ac8b840857ce..40649bce58d0 100644
--- a/misc/p5-LEGO-RCX/Makefile
+++ b/misc/p5-LEGO-RCX/Makefile
@@ -10,7 +10,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module for communicating with the Lego RCX brick via the IR tower
-PERL_CONFIGURE= yes
USES= perl5
USE_PERL5= configure
diff --git a/net/p5-Net-Address-IPv4-Local/Makefile b/net/p5-Net-Address-IPv4-Local/Makefile
index bad47fac9a2d..08f2d4c3ac65 100644
--- a/net/p5-Net-Address-IPv4-Local/Makefile
+++ b/net/p5-Net-Address-IPv4-Local/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Net-Address-IPv4-Local
-# Date created: 25 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Net-Address-IPv4-Local
PORTVERSION= 0.12
@@ -19,6 +15,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Net::Address::IPv4::Local.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/security/p5-Tree-Authz/Makefile b/security/p5-Tree-Authz/Makefile
index 7af5dbda0905..0b32bc522142 100644
--- a/security/p5-Tree-Authz/Makefile
+++ b/security/p5-Tree-Authz/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Tree-Authz
-# Date created: 22 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Tree-Authz
PORTVERSION= 0.03
@@ -22,6 +18,7 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
MAN3= Tree::Authz.3 Tree::Authz::Role.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/textproc/p5-AI-Categorizer/Makefile b/textproc/p5-AI-Categorizer/Makefile
index 193b163735da..e4d74559a90b 100644
--- a/textproc/p5-AI-Categorizer/Makefile
+++ b/textproc/p5-AI-Categorizer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: AI-Categorizer
-# Date created: 19 Feb 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= AI-Categorizer
PORTVERSION= 0.09
@@ -48,6 +44,7 @@ MAN3= AI::Categorizer.3 \
AI::Categorizer::Learner::Weka.3 \
AI::Categorizer::Storable.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/textproc/p5-Spreadsheet-WriteExcel-Styler/Makefile b/textproc/p5-Spreadsheet-WriteExcel-Styler/Makefile
index 2da92d1fc0a2..63d98b8de246 100644
--- a/textproc/p5-Spreadsheet-WriteExcel-Styler/Makefile
+++ b/textproc/p5-Spreadsheet-WriteExcel-Styler/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Styles for formatting Spreadsheet::WriteExcel
-PERL_MODBUILD= YES
+USES= perl5
+USE_PERL5= modbuild
MAN3= Spreadsheet::WriteExcel::Styler.3
diff --git a/textproc/p5-Text-Decorator/Makefile b/textproc/p5-Text-Decorator/Makefile
index 64236af49860..869829677f62 100644
--- a/textproc/p5-Text-Decorator/Makefile
+++ b/textproc/p5-Text-Decorator/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Text-Decorator
-# Date created: 05 Jun 06
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Text-Decorator
PORTVERSION= 1.65
@@ -28,6 +24,7 @@ MAN3= Text::Decorator.3 \
Text::Decorator::Group.3 \
Text::Decorator::Node.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Unaccent/Makefile b/textproc/p5-Text-Unaccent/Makefile
index 8d28c3a7631a..7e1559dbb0ad 100644
--- a/textproc/p5-Text-Unaccent/Makefile
+++ b/textproc/p5-Text-Unaccent/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Text-Unaccent
-# Date created: 25 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Text-Unaccent
PORTVERSION= 1.08
@@ -17,8 +13,8 @@ COMMENT= Remove accents from a string
MAN3= Text::Unaccent.3
-USES= iconv
-PERL_CONFIGURE= yes
+USES= iconv perl5
+USE_PERL5= configure
CFLAGS+= -DICONV_CONST=const
.include <bsd.port.mk>
diff --git a/textproc/p5-Unicode-Escape/Makefile b/textproc/p5-Unicode-Escape/Makefile
index edf03642f92a..f84712eb8ccc 100644
--- a/textproc/p5-Unicode-Escape/Makefile
+++ b/textproc/p5-Unicode-Escape/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Unicode-Escape
-# Date created: 29 Mar 2009
-# Whom: Vadim Vatlin
-#
+# Created by: Vadim Vatlin
# $FreeBSD$
-#
PORTNAME= Unicode-Escape
PORTVERSION= 0.0.2
@@ -17,7 +13,8 @@ COMMENT= Escape and unescape Unicode characters other than ASCII
BUILD_DEPENDS= p5-Unicode-String>=0:${PORTSDIR}/converters/p5-Unicode-String
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Unicode::Escape.3
diff --git a/textproc/p5-XML-XBEL/Makefile b/textproc/p5-XML-XBEL/Makefile
index 07e581eeec33..cb3f0728c7fd 100644
--- a/textproc/p5-XML-XBEL/Makefile
+++ b/textproc/p5-XML-XBEL/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-XML-XBEL
-# Date created: August 03, 2004
-# Whom: Aaron Straup Cope <ascope@cpan.org>
-#
+# Created by: Aaron Straup Cope <ascope@cpan.org>
# $FreeBSD$
-#
PORTNAME= XML-XBEL
PORTVERSION= 1.4
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= XML::XBEL.3 \
XML::XBEL::Alias.3 \
diff --git a/www/p5-CGI-Application-Dispatch-Server/Makefile b/www/p5-CGI-Application-Dispatch-Server/Makefile
index 12fc6e0e918d..9b5bcf2b05aa 100644
--- a/www/p5-CGI-Application-Dispatch-Server/Makefile
+++ b/www/p5-CGI-Application-Dispatch-Server/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-HTTP-Server-Simple-Static>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple-Static \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Dispatch::Server.3
diff --git a/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile b/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile
index 5fcc9e54a1f5..2da76b02e5af 100644
--- a/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile
+++ b/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/p5-CGI-Application-Plugin-AnyTemplate
-# Date created: 14 September 2005
-# Whom: George Hartzell <hartzell@alerce.com>
-#
+# Created by: George Hartzell <hartzell@alerce.com>
# $FreeBSD$
-#
PORTNAME= CGI-Application-Plugin-AnyTemplate
PORTVERSION= 0.18
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-CGI-Application-Plugin-Forward>=0:${PORTSDIR}/www/p5-CGI-Appli
p5-Clone>=0.23:${PORTSDIR}/devel/p5-Clone
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::AnyTemplate.3 \
CGI::Application::Plugin::AnyTemplate::Driver::HTMLTemplate.3 \
diff --git a/www/p5-CGI-Application-Plugin-Authentication/Makefile b/www/p5-CGI-Application-Plugin-Authentication/Makefile
index 115e00717925..3b94726eec35 100644
--- a/www/p5-CGI-Application-Plugin-Authentication/Makefile
+++ b/www/p5-CGI-Application-Plugin-Authentication/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS+= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken \
p5-Test-Warn>=0.11:${PORTSDIR}/devel/p5-Test-Warn
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::Authentication::Display.3 \
CGI::Application::Plugin::Authentication::Display::Basic.3 \
diff --git a/www/p5-CGI-Application-Plugin-Authorization/Makefile b/www/p5-CGI-Application-Plugin-Authorization/Makefile
index 1fe4b308cc31..38bcd6f975c8 100644
--- a/www/p5-CGI-Application-Plugin-Authorization/Makefile
+++ b/www/p5-CGI-Application-Plugin-Authorization/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::Authorization::Driver::Generic.3 \
CGI::Application::Plugin::Authorization::Driver.3 \
diff --git a/www/p5-CGI-Application-Plugin-HTMLPrototype/Makefile b/www/p5-CGI-Application-Plugin-HTMLPrototype/Makefile
index eed95f928199..2aa212f9801c 100644
--- a/www/p5-CGI-Application-Plugin-HTMLPrototype/Makefile
+++ b/www/p5-CGI-Application-Plugin-HTMLPrototype/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-HTML-Prototype>=0:${PORTSDIR}/www/p5-HTML-Prototype
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::HTMLPrototype.3
diff --git a/www/p5-CGI-Application-Plugin-LinkIntegrity/Makefile b/www/p5-CGI-Application-Plugin-LinkIntegrity/Makefile
index a2d60e653b16..453c3eb58021 100644
--- a/www/p5-CGI-Application-Plugin-LinkIntegrity/Makefile
+++ b/www/p5-CGI-Application-Plugin-LinkIntegrity/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-CGI-Application-Plugin-AutoRunmode>=0:${PORTSDIR}/www/p5-CGI-Application-Plugin-AutoRunmode
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::LinkIntegrity.3
diff --git a/www/p5-CGI-Application-Plugin-LogDispatch/Makefile b/www/p5-CGI-Application-Plugin-LogDispatch/Makefile
index fc237b628370..d715effcbc1d 100644
--- a/www/p5-CGI-Application-Plugin-LogDispatch/Makefile
+++ b/www/p5-CGI-Application-Plugin-LogDispatch/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::LogDispatch.3
diff --git a/www/p5-CGI-Application-Plugin-MessageStack/Makefile b/www/p5-CGI-Application-Plugin-MessageStack/Makefile
index f563dc8986e0..4d07a8f31b63 100644
--- a/www/p5-CGI-Application-Plugin-MessageStack/Makefile
+++ b/www/p5-CGI-Application-Plugin-MessageStack/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-CGI-Application-Plugin-TT>=0:${PORTSDIR}/www/p5-CGI-Application-Plugin-TT
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::MessageStack.3
diff --git a/www/p5-CGI-Application-Plugin-Redirect/Makefile b/www/p5-CGI-Application-Plugin-Redirect/Makefile
index 612ae96a9eb2..272458225eb9 100644
--- a/www/p5-CGI-Application-Plugin-Redirect/Makefile
+++ b/www/p5-CGI-Application-Plugin-Redirect/Makefile
@@ -13,7 +13,8 @@ COMMENT= Easy external redirects in CGI::Application
RUN_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::Redirect.3
diff --git a/www/p5-CGI-Application-Plugin-Session/Makefile b/www/p5-CGI-Application-Plugin-Session/Makefile
index b5ffd04c2f99..87c5a9eee6d4 100644
--- a/www/p5-CGI-Application-Plugin-Session/Makefile
+++ b/www/p5-CGI-Application-Plugin-Session/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::Session.3
diff --git a/www/p5-CGI-Application-Plugin-Stream/Makefile b/www/p5-CGI-Application-Plugin-Stream/Makefile
index c45a7d979803..6a15a46c3afd 100644
--- a/www/p5-CGI-Application-Plugin-Stream/Makefile
+++ b/www/p5-CGI-Application-Plugin-Stream/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::Stream.3
diff --git a/www/p5-CGI-Application-Plugin-TT/Makefile b/www/p5-CGI-Application-Plugin-TT/Makefile
index f3891b362f08..a347b8f773a7 100644
--- a/www/p5-CGI-Application-Plugin-TT/Makefile
+++ b/www/p5-CGI-Application-Plugin-TT/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-CGI-Application-Plugin-DevPopup>=0:${PORTSDIR}/www/p5-CGI-Application-Plugin-DevPopup
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::TT.3
diff --git a/www/p5-CGI-Application-Plugin-ViewCode/Makefile b/www/p5-CGI-Application-Plugin-ViewCode/Makefile
index 84ff94759629..141efbc11c6a 100644
--- a/www/p5-CGI-Application-Plugin-ViewCode/Makefile
+++ b/www/p5-CGI-Application-Plugin-ViewCode/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
p5-Test-LongString>=0:${PORTSDIR}/devel/p5-Test-LongString
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Application::Plugin::ViewCode.3
diff --git a/www/p5-Catalyst-Controller-BindLex/Makefile b/www/p5-Catalyst-Controller-BindLex/Makefile
index 3c615360d24b..f047efa249c6 100644
--- a/www/p5-Catalyst-Controller-BindLex/Makefile
+++ b/www/p5-Catalyst-Controller-BindLex/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Catalyst::Controller::BindLex.3
diff --git a/www/p5-Template-Iterator-AlzaboWrapperCursor/Makefile b/www/p5-Template-Iterator-AlzaboWrapperCursor/Makefile
index 1b1ab158224f..886c3762c8aa 100644
--- a/www/p5-Template-Iterator-AlzaboWrapperCursor/Makefile
+++ b/www/p5-Template-Iterator-AlzaboWrapperCursor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Template-Iterator-AlzaboWrapperCursor
-# Date created: 2 August 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Template-Iterator-AlzaboWrapperCursor
DISTVERSION= 0.01
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-Template-Toolkit>=2:${PORTSDIR}/www/p5-Template-Toolkit \
p5-Class-AlzaboWrapper>=0:${PORTSDIR}/devel/p5-Class-AlzaboWrapper
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= YES
+USES= perl5
+USE_PERL5= modbuild
MAN3= ${PORTNAME:S/-/::/g}.3
diff --git a/x11-toolkits/p5-Gnome2-Canvas/Makefile b/x11-toolkits/p5-Gnome2-Canvas/Makefile
index 908d69c2c935..938908d8c682 100644
--- a/x11-toolkits/p5-Gnome2-Canvas/Makefile
+++ b/x11-toolkits/p5-Gnome2-Canvas/Makefile
@@ -21,8 +21,8 @@ RUN_DEPENDS= p5-Glib2>=0:${PORTSDIR}/devel/p5-Glib2 \
p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
USE_GNOME= libgnomecanvas
-USES= pkgconfig
-PERL_CONFIGURE= yes
+USES= pkgconfig perl5
+USE_PERL5= configure
MAKE_JOBS_UNSAFE= yes
post-install:
diff --git a/x11-toolkits/p5-Gnome2-VFS/Makefile b/x11-toolkits/p5-Gnome2-VFS/Makefile
index 8dc2a0d6c6fe..a58f97d8a550 100644
--- a/x11-toolkits/p5-Gnome2-VFS/Makefile
+++ b/x11-toolkits/p5-Gnome2-VFS/Makefile
@@ -20,8 +20,8 @@ RUN_DEPENDS= p5-Glib2>=0:${PORTSDIR}/devel/p5-Glib2 \
p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
USE_GNOME= gnomevfs2
-USES= pkgconfig
-PERL_CONFIGURE= yes
+USES= pkgconfig perl5
+USE_PERL5= configure
MAKE_JOBS_UNSAFE= yes
post-install:
diff --git a/x11-toolkits/p5-Gtk2-Html2/Makefile b/x11-toolkits/p5-Gtk2-Html2/Makefile
index 65128e97a996..22e91c2a0afe 100644
--- a/x11-toolkits/p5-Gtk2-Html2/Makefile
+++ b/x11-toolkits/p5-Gtk2-Html2/Makefile
@@ -20,8 +20,8 @@ RUN_DEPENDS= p5-Glib2>=0:${PORTSDIR}/devel/p5-Glib2 \
p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
USE_GNOME= libgtkhtml
-USES= pkgconfig
-PERL_CONFIGURE= yes
+USES= pkgconfig perl5
+USE_PERL5= configure
MAKE_JOBS_UNSAFE= yes
post-install: